آموزش ابتدایی کانفیگ سوئیچ سیسکو

اموزش مقدماتی سیسکو

اموزش مقدماتی سیسکو

آموزش ابتدایی کانفیگ سوئیچ سیسکو 

آموزش کانفیگ و راه اندازی مقدماتی سوئیچ سیسکو

کانفیگ سوئیچ سیسکو برای راه اندازی و استفاده ، کار چندان سختی نیست ! با هم شروع کنیم …

فرض کنید یک سوئیچ سیسکو 2960 خریداری کرده اید و نیاز دارید که ابتدا یک یوزر روی آن بسازید و بتوانید با تعریف یک IP به آن تلنت کنید . یا مثلا هر پورت سوئیچ سیسکو 2960 را عضو یک VLAN نمائید ، یا یک پورت را جهت اتصال به یک سوئیچ سیسکو دیگر و یا روتر سیسکو ترانک کنید ، یا برای مثال سوئیچ شما از POE پشتیبانی میکند و میخواهید IPPhone یا IP Cam یا Wireless Radio را با آن روشن کنید …

در این مقاله سعی داریم که به شکل مقدماتی و برای رفع مقطعی مشکلات دوستان به آموزش سطحی برخی از این کاربرد ها در حد طرح کامند بپردازیم :

برای شروع ابتدا سوئیچ سیسکو را با کابل کنسول سیسکو به یک PC با پورت سریال متصل و با یک برنامه ترمینال مثل Putty به آن متصل شوید . ( میتوانید با کلیک بر روی نام putty انرا دریافت کنید )

۱- ساخت username و password و ایجاد سطح دسترسی :

switch>enable          ” ورود به محیط privilage “

switch#conf t           “وارد شدن به محیط کانفیگ “

switch(config)#aaa new-model

switch(config)#username shabake password 0 shabake

switch(config)#enable secret shabake

۲ – اختصاص دادن یک IP و default gateway به سوئیچ برای دسترسی IP :

switch(config)#int vlan 1 ( کانفیگ وی لن ۱ )

switch(config-if)#ip add 192.168.1.1 255.255.255.0 ( اختصاص آدرس )

switch(config-if)#no sh

switch(config-if)#exit

switch#vlan database

switch(vlan)#vlan 1 name shabake (ساخت وی لن ۱ )

switch(vlan)#exit

switch#conf t

switch(config)#ip default-gateway 192.168.1.2 ( آدرس روتر )

با این روش که ملاحظه کردید به راحتی میتوانید یک vlan بسازید و به آن IP اختصاص دهید ، توجه کنید که vlan 1 به شکل پیشفرض ساخته شده و تمامی پورت ها عضو vlan 1 هستند .

۳ – اختصاص هر پورت به vlan خاص :

براس مثال میخواهید چند پورت عضو Vlan خاصی باشند ، ابتدا با روش بالا vlan ها را بسازید ( Vlan database ) ، نیازی هم به اختصاص IP به هر vlan نیست ، سپس ، با روش زیر هر پورت را عضو vlan مورد نظر کنید :

switch(config)#int fas 0/1

switch(config-if)#description “connected to cisco router”

switch(config-if)#switchport access vlan 10

switch(config-if)#exit

switch(config)#int fas 0/2

switch(config-if)#description “web Server”

switch(config-if)#switchport access vlan 20

switch(config-if)#exit

ت.جه داشته باشید در هر لحظه میتوانید با دستور زیر تغییرات را زخیره کنید ، در غیر این صورت بعد از خاموش روشن کردن سوئیچ ، کانفیگی وجود نخواهد داشت !

switch#write mem

۴- کتنفیگ پورت سوئیچ سیسکو برای مود ترانک :

ترانک نوعی ارتباط است که حامل vlan هاست ! این ساده ترین نوع توضیح است ! برای مثال شما ۲ سوئیچ سیسکو دارید و روی هر سوئیچ 3 عدد vlan به شماره های 10-20-30  ، حال میخواهید nod هایی از هر سوئیچ امکان دسترسی به nod های سوئیچ دیگر که در همان vlan هستند داشته باشند .

switch-a(config)#int gi 0/1

switch-a(config-if)#description “Trunk to switch B”

switch-a(config-if)#switchport mode trunk

مشابه همین تنظیمات را در سمت دیگر نیز انجام داده و سوئیچ ها را توسط این پورت به هم متصل کنید . به همین سادگی …

۵ – استفاده از امکان POE : یکی از قابلیت های سوئیچ های سیسکو ، امکان پشتیبانی از POE یا همان استاندارد 802.3af که برق را با ولتاژ 48v به نود ارسال کرده و امکان روشن کردن دیوایس هایی که از poe پشتیبانی میکنند مثل IP Phone – IP Cam – Wireless radio  و … را دارد .

switch(config)#int fas 0/1

switch(config-if)#power inline auto

دستور فوق باعث میشود  ، در صورتی که دیوایس متصل شده به سوئیچ سیسکو قابلیت POE را دارا بود ، ولتاژ به آن ارسال شود .

خب چند نکته ، سوئیچ های سیسکو یک Vlan Database دارند که اطلاعات هر Vlan در آن ذخیره و میتوان آنرا توسط VTP ( میتوانید در مقاله ای مجزا آنرا یاد بگیرید ! ) با سایر سوئیچ های سیسکو به اشتراک گذاشت ، برای ایجاد هر Vlan حتما باید آن Vlan در vlan database موجود باشد  .

سوئیچ های لایه ۲ سیسکو قابلیت IP Routing نداشته و برای Routing میبایست از یک روتر برای inter vlan routing استفاده کرد .

سوئیچ های سیسکو به صورت پیشفرض به صورت یک سوئیچ معمولی عمل میکنند و تمامی پورت های آنها در حالت فعال و ب صورت پیشفرض عضو vlan 1 هستند ، پس میتوانید از باکس خارج کنید و به برق بزنید و استفاده کنید .

این آموزه ها فقط جنبه ابتدایی و سطحی داشته و همیشه میبایست مطالب را به صورت عمیق و کامل مطالعه فرمائید ،  دانستن کامند ممکن است ظاهرا مشکل فعلی شما را حل کند ، ولی راه حل صحیح این نیست !

وفقک الله

35 فکر می‌کنند “آموزش ابتدایی کانفیگ سوئیچ سیسکو

  1. بازتاب: آموزش ابتدایی کانفیگ سوئیچ سیسکو | مرکز آموزش یوسرور - هاست اشتراکی - سرور مجای با کیفیت

  2. hassan saffari

    با سلام
    ضمن تشکر خواشمندم در مورد config اطلاعات بیشتری برای اینجانب ارسال نمائید

  3. حوری

    با سلام
    ممنون از مطالب آموزشی که در مورد کانفیگ سوئیچ سیسکو گذاشتید.
    آیا نرم افزاری وجوددارد که به صورت مجازی امکان کانفیگ سوئیچ های سیسکو را داشته باشد. منظورم ایجاد محیطی شبیه محیط کانفیگ سوئیچ های سیسکو است. و از کجا می توانم دانلود کنم.

    با تشکر و احترام

  4. sareh

    سلام و خسته نباشید
    ممنون ازتون بخاطر این اطلاعات خوب
    اینا کل کامند های سوئیچ هستند؟؟؟
    برای امنیت سوئیچ ها چه کامند هایی استفاده میشه؟؟
    ممنون میشم زود جوابمو بدید

    1. امیرخسرو احمدی نویسنده

      سلام
      با تشکر از حسن نظرتون : )
      اگه منظورتون از کل کامند ها ، کل دستور های قابل اجرا رو یک سوئیچ هست ، که باید خدمتتون عرض کنم ، خیلی خیلی بیشتر از این حرفاس و سالیان سال زحمت و مطالعه میطلبه که شما به مدارجی مثل CCIE R&S برسی و کل کامند ها رو مسلط باشید رووش .
      این کامند ها ، همونطور که ذکر شد ، برای راه اندازی اولیه سوئیج و برآورده کردن همون نیاز های اولیه برای اغلب تازه کارهاست .
      در زمینه امنیت سوئیچ بحث بسیاره و ان شاالله حتما یه مقاله خواهیم گذاشت ، نقدا شما میتونید مقاله مربوط به امن سازی روتر سیسکو رو مطالعه کنید که کمی میتونه بهتون کمک کنه :
      ایمن سازی روتر سیسکو
      اگر سوالی داشتید ، خوشحال میشیم کمکتون کنیم
      موفق باشید

  5. حوری

    سلام
    ممنون از آموزشهای خوبتون.
    دستوراتی که برای ساخت وی لن نوشته بودید را در محیط packet tracer امتحان کردم ولی این errore
    Invalid input detected at ‘^’ marker
    را مشاهده کردم. لطفاً راهنمایی کنید.

    با تشکر

    1. امیرخسرو احمدی نویسنده

      سلام
      با تشکر از توجهتون ،
      در بعضی از ورژن های جدیدتر IOS ، برای مدیریت vlan ها میبایست آنها را در محیط Config و نه در Vlan Database انجام دهید
      مثلا :
      Aka-2960G48-Dakal#conf t
      Enter configuration commands, one per line. End with CNTL/Z.
      Aka-2960G48-Dakal(config)#vlan 10

  6. افشین شیرین زاده

    با سلام
    ضمن تشکر از سایت و اطلاعات خوبتان من دو عدد سوئیچ یکی core 3750 و دیگری 2960sl دارم
    در سوئیچ 3750 چند vlan متفاوت تعریف شده است و من یکی از پرتها را در هردو سوئیچ ترانک کرده ام و چند تنظیم دیگر ولی به محض اینکه دو پرت ترانک به یکدیگر متصل میشوند سوئیچ 3750 آن پرت را erore داده و غیر فعال میکند ر زیر نمونه کانفیگ را میگذارم ممنون میشوم در صورت امکان راهنمایی بفرمائید از وقت و توجهتان بسیار سپاسگذارم
    Config 3750 Core switch
    !
    interface GigabitEthernet1/0/33
    description trunk hesabdari
    switchport trunk encapsulation dot1q
    switchport mode trunk
    macro description cisco-desktop | cisco-desktop
    spanning-tree portfast
    spanning-tree bpduguard enable
    !

    !
    interface Vlan15
    description maskanshahri-vlan
    ip address 172.17.15.1 255.255.255.0
    ip helper-address 10.10.20.20
    !
    !
    ip default-gateway 10.10.20.20
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.10.20.20
    ip route 192.168.18.0 255.255.255.0 10.10.20.1
    ip http server
    !

    ***************Config 2960 switch*********************************************
    !
    interface Gigabir eternet 0/2
    no ip address
    switchport trunk allowed vlan 1-100
    switchport mode trunk
    !

    interface Vlan1
    ip address 10.10.20.9 255.255.255.0
    !
    ip http server
    ip http secure-server
    !

    *Mar 1 03:23:30.840: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed stat
    e to up
    *Mar 1 03:23:32.853: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth
    ernet0/2, changed state to up
    *Mar 1 03:23:35.281: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth
    ernet0/2, changed state to down
    *Mar 1 03:23:36.293: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed stat
    e to down

    port is errore or disabled

    1. امیرخسرو احمدی نویسنده

      سلام
      البته توو این log ای که فرستادین نشون میده که سویچ 2960 پورت رو down میکنه ،
      اگر ممکنه ، لاگ کامل و دقیق را ارسال کنید .
      این کامند رو هم تست کنید : show interface status err-disabled
      در هر صورت خوندن این مطلب رو بهتون توصیه میکنم :
      http://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/69980-errdisable-recovery.html

  7. افشین شیرین زاده

    با سلام و تشکر
    از راهنمائیتون خیلی ممنونم
    لینکتون خیلی مفید بود مشکل هم از bpdguard می باشد
    Gi1/0/33 trunk hesabdari err-disabled bpduguard
    ولی متاسفانه حل نشد
    در صورت امکان راهنمائی بیشتری بفرمائید
    یا اگر امکان داره تلفنی مزاحمتون بشم
    جسارتآاگر هزینه ای هم داره من درخدمتم
    09153017710

    این هم لاگ هر دو دستگاه

    ************——– 3750 switch *****************———-

    Log Buffer (4096 bytes):

    138472: Jan 27 08:59:04: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/33, change
    d state to up
    138473: Jan 27 08:59:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabit
    Ethernet1/0/33, changed state to up
    138474: Jan 27 08:59:07: %SPANTREE-2-BLOCK_BPDUGUARD: Received BPDU on port Giga
    bitEthernet1/0/33 with BPDU Guard enabled. Disabling port.
    138475: Jan 27 08:59:07: %PM-4-ERR_DISABLE: bpduguard error detected on Gi1/0/33
    , putting Gi1/0/33 in err-disable state
    138476: Jan 27 08:59:08: %LINEPROTO-5-UPDOWN: Line protocol on Interface Gigabit
    Ethernet1/0/33, changed state to down
    138477: Jan 27 08:59:09: %LINK-3-UPDOWN: Interface GigabitEthernet1/0/33, change
    d state to down

    *******************——— 2960 switch *******************************

    Trap logging: level informational, 47 message lines logged
    –More–
    *Mar 1 00:13:18.658: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t
    ftp://255.255.255.255/cisconet.cf d
    Log Buffer (4096 bytes):

    *Mar 1 00:12:36.610: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t
    ftp://255.255.255.255/network-confg) failed
    *Mar 1 00:12:51.647: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed stat
    e to up
    *Mar 1 00:12:53.723: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth
    ernet0/1, changed state to up
    *Mar 1 00:12:55.301: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth
    ernet0/1, changed state to down
    *Mar 1 00:12:56.313: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed stat
    e to down
    *Mar 1 00:13:18.658: %SYS-4-CONFIG_RESOLVE_FAILURE: System config parse from (t
    ftp://255.255.255.255/cisconet.cfg) failed

    1. امیرخسرو احمدی نویسنده

      سلام
      به نظر من بهتره مشکل رو حل کنید ، یکی از دلایل این مشکل اینه که شما این پورت رو در حالت portfast به یک دیوایس دیگر که BPDU تولید میکنه ، مثل یک سوئیچ متصل کردید ، که در این صورت STP برای حفاظت از خودش ، اون اینترفیس رو disable میکنه ، در قدم اول اینترفیس های دو سمت رو از حالت spaning tree port fast خارج کنید ، ولی فی المجلس گمون کنم این کامند سوئیچ رو در برابر تشخیص مشکل و خاموش کردن اینترفیس بی تفاوت میکنه :
      no errdisable detect cause bpduguard

      البته میتونید bpdugaurd رو هم غیر فعال کنید که اگه stp دارین ، توصیه نمیکنم .
      اینو تست کنید ، اگر حل نشد ، من باز در خدمتم.

      وفقک الله

  8. رضا

    سلام ، یک سوییچ دارم boot نمس شه لطفا راهنمایی کنید. ایم
    switch: boot
    Loading “flash:/c2960-lanbasek9-mz.122-50.SE4/c2960-lanbasek9-mz.122-50.SE4.bin”
    …flash:/c2960-lanbasek9-mz.122-50.SE4/c2960-lanbasek9-mz.122-50.SE4.bin: short
    read: bad mzip file

    Error loading “flash:/c2960-lanbasek9-mz.122-50.SE4/c2960-lanbasek9-mz.122-50.SE
    4.bin”

    Interrupt within 5 seconds to abort boot process.
    Boot process failed…

  9. محمدرضا

    سلام؛خسته نباشید؛
    یک سوال داشتم.
    من به تازگی یک سوئیچ 2960 خریدم ، وقتی میزارمش داخل شبکه بعد از چند ساعت دیگه Ping نمیشه و شبکه کلیه کامپیوترها یی که بهش وصل هستن قطع میشه.
    به نظره شما مشکل از کجاست؟
    ممنون.

  10. محمد

    با سلام
    ببخشید من میخوام snmp رو روی سوئیچ کانفیگ کنم و توسط نرم افزار prtg مانیتور کنم البته از نرم افزار شبیه ساز سوئیچ استفاده میکنم میشه راهنماییم کنید .ممنون

    1. امیرخسرو احمدی نویسنده

      سلام
      کافیه که یه SNMP community تعریف کنید :
      snmp-server community PUBLIC RO
      در اینجا PUBLIC در واقع همون کامونیتیه که میتونید هرچیزی بذارید و RO به معنی Read Only

  11. محمدی

    سلام. برای ارتباط vlan ها باهم ازطریق روتر، در packet tracer از چه سوییچی میتونم استفاده کنم که encapsulation رو ساپورت کنه ؟؟؟

  12. نیما

    با سلام و تشکر

    اصولی ترین روش کانفیگ سوئیچ های سیسکو وارد کردن دستورات CLI است ؟
    اگر اینطور هست ، اصولی ترین راه برای وارد کردن این دستورات توسط چه نرم افزار توصیه شده ای از طرف سیسکو می باشد ؟
    Putty یک نمونه ای بود که شما مثال زدید.

    1. امیرخسرو احمدی نویسنده

      سلام دوست عزیز
      همونطور که در متن هم اشاره شد استفاده از terminal یکی از اصلی ترین و اصولی ترین را های سنتی و حرفه ای کانفیگ دایوایس هاست ،، فرقی هم بین سیسکو . بقیه برند ها نداره ،، با اینکه همه برند ها سعی کردن محیط های مدیریتی گرافیکی و وب بیس و نرم افزار های مدیریتی ارائه بدن ،، لیکن ،، حرفه ای ها همیشه ترجیح میدند که از خط فرمان استفاده کنند.
      putty هم نمونه ای از Client هاییه که قابلیت SSH – Telnet – Terminal رو به ساده ترین شکل به شما ارائه میده ،، و در امتحانات رسمی سیسکو هم یکی از انتخاب هاست ،، بنابراین ما هم به همین نرم افزار اشاره کردیم و توصیه میکنیم که مهارتتون رو با این نرم افزار کلاینت افزایش بدید که در امتحانات سیسکو بتونید بهتر عمل کنید .

      موفق باشید

  13. اسماعیلی

    سلام خسته نباشید من پروژه می نویسم اما با مشکل مواجه شدم من دو تا vlan دارم که هر کدام به یک سوئیچ متصل هستن و می خوام ای دو سوئیچ لایه ی 2 را به سوئیچ لایه ی 3 متصل کنم اما نمی دونم چه جوری میشه کمکم کنین؟

  14. علی

    سلام
    ممنون بابت سایت خیلی خوبتون
    بسیار ساده و کارآمد…
    آیا مقاله ای دارید که از ابتدای پیکربندی سوئیچ ها رو داشته باشه
    با سپاس

پاسخ دهید

نشانی ایمیل شما منتشر نخواهد شد. بخش‌های موردنیاز علامت‌گذاری شده‌اند *