بایگانی برچسب: s

شبکه سیسکو

آموزش کانفیگ روتر سیسکو PPPOE Dialer – PPPOE RAS

سیسکو pppoe

سیسکو pppoe client – server

آموزش کانفیگ روتر سیسکو PPPOE Dialer – PPPOE RAS

آموزش کانفیگ روتر سیسکو  PPPOE Server , PPPOE Client

PPPOE یکی از انواع ارتباطات پروتکل PPP برای بستر های لایه ۲ مثل xDsl و Lan هاست که به شکل وسیعی در سرویس دهی ADSL مورد استفاده قرار میگیرد .

روتر های سیسکو یکی از بهترین گزینه ها برای استفاده به عنوان PPPOE RAS میباشند ، هم به لحاظ انعطاف بالا ، هم قدرت بالای پردازشی و امکان انتگریت شدن با بقیه سرویس های شبکه و روتینگ پروتکل ها .

برای مثال اکثر ISDP های ایرانی از روتر سیسکو به عنوان PPPOE RAS جهت ارتباط کاربران ADSL  استفاده میکنند .

در این مقال ما به اجمال به آموزش روش کانفیگ روتر سیسکو به عنوان PPPOE Dialer – PPPOE RAS خواهیم پرداخت که در صورت تمایل میتوانید مطالعات بیشتر را در منابع سیسکو دنبال فرمایید .

PPPOE RAS Server :

bba-group pppoe global

virtual-template 1

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255.0

load-interval 30

duplex auto

speed auto

pppoe enable group global

!

interface Virtual-Template1

mtu 1492

ip unnumbered FastEthernet0/0

peer default ip address pool shabake

ppp authentication pap chap

!

ip local pool shabake 10.0.0.1 10.0.0.200

PPPOE Dialer :

interface FastEthernet0/0

no ip address

no ip redirects

no ip unreachable

no ip proxy-arp

ip virtual-reassembly

ip tcp adjust-mss 1452

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp pap sent-username shabake password shabake

ppp chap hostname shabake

ppp chap password shabake

!

ip route 0.0.0.0 0.0.0.0 Dialer1

 نکته مهم و قابل توجه اینکه در بعضی موارد ، وقتی از روتر سیسکو به عنوان PPPOE Dialer استفاده میشود و برای مثال ترافیک Internet بر روی ارتباط PPPOE ، جهت دسترسی به اینترنت NAT میشود ، شاهده میشود که صفحات یا باز نمیشوند ، یا به کندی و نصفه ، که مشکل از تنظیمات مربوط به MTU و TCP MSS است .

به دلیل اینکه خود PPPOE Header حدودا 8 بایت طول داشته ، و باعث override شدن سایز MTU و شکستن پکت ها خواهند شد ، در آینده مقاله ای مفصل در رابطه با  حل مشکلات MTU و MRU و TCP MSS منتشر خواهیم نمود .

The Ethernet payload for PPPoE is as follows:

                        1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |  VER  | TYPE  |      CODE     |          SESSION_ID           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |            LENGTH             |           payload             ~
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

وفقک الله

Aka Networks

سیسکو 3945

فروش روتر سیسکو 3945 – Cisco ISR 3945

روتر سیسکو 3945

روتر سیسکو 3945

فروش روتر سیسکو 3945 – Cisco ISR G2 3945

روتر سیسکو 3945

روتر سیسکو 3945 , قوی ترین مدل روتر سیسکو از سری جدید روتر های نسل دوم سیسکو ISR G2 ، روتر سیسکو 3945 می باشد .

فرق اصلی سری جدید روتر های سیسکو نسل دوم ISR ، دو هسته شدن پردازنده های CPU اصلی روتر میباشد .

یکی از مزایای دیگر روتر سیسکو 3945 پشتیبانی از سری جدید ماژول ها و همچنین افزایش پورت ها به 3 عدد پورت گیگ همراه با SFP و کانکتور جدید کنسول که USB می باشد .

با توجه به افزایش تعداد هسته core های پردازنده روتر سیسکو 3945 ، میتوان انتظار داشت که روتر سیسکو 3945 قادر است تا حدود 300 مگابیت ترافیک اینترنتی را ، مسیریابی نماید ، که این عدد توسط اینجانب و تعدادی از سایت های بنچمارک ، تست و تایید گردیده .

با توجه به End of Sale شدن سری روتر سیسکو 3800 و قیمت مناسب و امکانات و قابلیت های بالای سری 3900 ، روتر سیسکو 3900 را یکی از انتخاب های مناسب برای کسب و کار های متوسط و یا ISP های کوچک ، بر شمرد .

شاید بتوان گفت ، یکی از نقاط ضعف سری جدید ISR های سیسکو ، نیاز به خرید لایسنس برای فعال سازی امکانات بیشتر ، که پیشتر به راحتی با آپگرید IOS ، انجام میپذیرفت ، دانست …

از نظر قدرت پردازشی و تنوع ماژول های نسل جدید سیسکو ، و فارغ از کلاس کاری ، شاید بتوان روتر سیسکو 3945 را رقیب سری روتر 7200 سیسکو ، سیسکو 7206 NPE G2 VXR ، دانست که البته بنچمارک های موجود و تجربیات شخصی اینجانب ، گواه عملکرد بهتر روتر سیسکو 3945 در سناریو های سرویس دهی اینترنت بوده است .

در مجموع روتر سیسکو 3945 و روتر سیسکو 3925 و مدل Enhanced و K9 این سری ، بسیار مناسب جهت کسب کارهای متوسط ، سازمانها ، شرکت ها با نیاز به انواع سرویس های WAN بر روی بستر های مختلف و همچنین Unified Communication  ، سرویس های Voice and Video Stream ، مجازی سازی Visualizatio و همیچنین ISP های متوسط با حداکثر پهنای باند 300 مگابیت ، جهت Core یا Branch Router  است .

از دیگر مزایای بسیار ارزشمند روتر سیسکو 3945 پشتیبانی از نسل جدید ماژول های UCS سیسکو ، که راه را برای مجازی سازی هموار مینماید ، از جمله این ماژول ها میتوان به :

UCS-E160D-M1/K9

UCS-E160DP-M1/K9

UCS-E140D-M1/K9

سیسکو ucs e

سیسکو ucs e

ماژول های سری UCS E قدرت گرفته از Intel Xeon CPU با تعداد Core های متفاوت و میزان رم بالا و استفاده از هارد دیسک های SATA – SAS – SSD امکان استفاده از روتر به عنوان یه Bade Server جهت انواع مصارف از جمله Microsoft Active Directory ، راه اندازی انواع سرویس های DHCP – HTTP- DNS – POS و حتی نصب انواع توزیع های لینوکس و VmWare را مهیا میسازد ، که این انقلابی در تولید Intgrated Service Router هاست .

برای مثال اینجانب از روتر سیسکو 3945 به همراه HWIC و ماژول UCS-E140DP-M1/K9 ، اقدام به نصب و راه اندازی Cisco Unified Manager برای سازمانی نمودم ، که البته این روتر مسئولیت Routing داخلی ، BGP ، MPLS VPN , Nat , Firewall , Voip Gateway را نیز به راحتی به دوش میکشید .

از دیگر ماژول های نسل جدید و پر کاربرد قابل نصب روی روتر سیسکو 3945 میتوان به Cisco SM-X EtherSwitch Service Modules  اشاره کرد ، برای نمونه ماژول های : SM-X-ES3-24-P ، SM-D-ES3G-48-P که 24 یا 48 پورت 10/100/1000 لایه 2/3 را به روتر اضافه مینماید .

SM-D-ES3G-48-P

SM-D-ES3G-48-P

قابلیت نصب انواع Wireless Controller و 3G/LTE ماژول ها قابلیت ترتباطات وایرلس و 3G/LTE را به روتر سیسکو 3945 اضافه مینماید .

همچنین امکان پشتیبانی از انواع ماژول ها و Hwic – Vic های Voice و انواع ماژول های WAN جهت ارتباطات E1/T1 ISDN و همچنین ATM OC3   امکان اتصال روتر سیسکو 3945 را به انواع بستر های ارتباطی میدهد .

قیمت روتر سیسکو 3945 ، در ابتدای تولید و ورود به ایران حتی زیر 10 ملیون تومان بوده ولی همکنون مدل ساده IP service را میتوانید زیر 30 ملیون خریداری و برای فعال سازی هر Feature نیاز به خریداری Licence مورد نظر نمایید .

در ذیل به برسی مشخصات فنی روتر سیسکو 3945 و همچنین برخی بنچمارک های Cisco ISR G2 3945 می پردازیم :

نمای پورت های سیسکو 3945

نمای پورت های سیسکو 3945

روتر سیسکو 3945 دارای SPE 150 که قابلیت آپگرید جهت سرویس دهی بهتر WAN میباشد .

روتر سیسکو 3945 دارای 3 پورت 10/100/1000 که شامل 2 پورت SFP و 1 پورت Gigabit Ethernet است

روتر سیسکو 3945E دارای 4 پورت 10/100/1000 که شامل 2 پورت SFP و 2 پورت Gigabit Ethernet است

روتر سیسکو 3945 شامل 4 درگاه توسعه EHWIC – nterface slots (enhanced high-speed WAN interface card .

روتر سیسکو 3945E شامل 3 درگاه توسعه EHWIC – nterface slots (enhanced high-speed WAN interface card .

روتر سیسکو 3945 دارای 4 اسلات Service-module slots جهت نصب انواع سرویس انجین ها میباشد .

روتر سیسکو 3945 دارای یک عدد Integrated services module (ISM) slots به شکل Default میباشد .

روتر سیسکو 3945 امکان نصب 4 عدد Packet-voice data-module (PVDM)  را داراست.

همچنین روتر سیسکو 3945 دارای 4 پورت USB 2 و به میزان 256 MB حافظه Flash قابل ارتقا تا 8GB و 1GB قابل ارتقا تا 4GB حافظه رم را داراست .

3945 Benchmark

3945 Benchmark میزان پهنای باند

3945 Benchmark

3945 Benchmark

سیسکو 3945 بنچمارک

سیسکو 3945 بنچمارک سایت شرکت سیسکو

Cisco 3945 Wan performance

Cisco 3945 Wan performance

 

 

 

جهت اطلاعات بیشتر در مورد روتر سیسکو3945 ، مشاوره خرید روتر سیسکو 3945 و دریافت قیمت روتر سیسکو 3945 میتوانید با ما تماس بگیرید : 66562270 -021 , 66381600 021 , 09121308444

Aka Networks

سیسکو

سیسکو را آپدیت کنید !!

لوگوی سیسکو

 

سیسکو را آپدیت کنید !!

هشدار در مورد سه مورد باگ امنیتی خطر ناک در محصولات سیسکو

اول : سیسکو به تازگی دست به انتشار آپدیتی برای باگ امنیتی دیوایس های IPS خود نموده است .

اگر هرکدام از دیوایس های زیر را دارید ، حتما به فکر آپدیت باشید :

Cisco ASA 5500 Series Advanced Inspection and Prevention Security Services Module (AIP SSM)
Cisco ASA 5500-X Series IPS Security Services Processor (IPS SSP) software and hardware modules
Cisco ASA 5505 Advanced Inspection and Prevention Security Services Card (AIP SSC)
Cisco IPS 4200 Series Sensors
Cisco IPS 4300 Series Sensors
Cisco IPS 4500 Series Sensors

به نقل از فن آوری اطلاعات ایران، هر سه آسیب پذیری موجود در این محصولات مربوط به آسیب پذیری انکار سرویس Denial of service می باشد. برخی از این محصولات می توانند از راه دور و بدون تایید هویت مورد حمله قرار گیرند در نتیجه به روز رسانی ها باید در اسرع وقت اعمال شوند.

دومین راهنمایی امنیتی یک آسیب پذیری دسترسی غیرمجاز را در Cisco Unified SIP Phone 3905 توصیف می کند. با سواستفاده از این آسیب پذیری، یک مهاجم راه دور می تواند بدون تایید هویت دسترسی root دستگاه آلوده را بدست آورد. میان نرم افزار Cisco Unified SIP Phone 3905 نسخه های پیش از ۹٫۴(۱) تحت تاثیر این آسیب پذیری قرار دارند. هم چنین سیسکو روش های کاهش مخاطرات را برای این محصولات مانند امضای IPS در نظر گرفته است.

دوم : آپدیت امنیتی مربوط به آسیب پذیری های موجود در نرم افزار Cisco Unified Computing System (UCS) Director نسخه های پیش از Cisco UCS Director Release 4.0.0.3 HOTFIX می شود. یک آسیب پذیری در UCS Director می تواند به یک مهاجم راه دور اجازه دهد تا بدون تایید هویت کنترل کامل دستگاه آلوده را در اختیار بگیرد.

سوم : آپدیت امنیتی  مربوط به نرم افزار (Cisco Firewal Services Module ) (FWSM ) می باشد. این آسیب پذیری یک آسیب پذیری شرایط رقابتی هنگام تخصیص مجدد حافظه است.

یک مهاجم می تواند با ارسال ترافیک مناسب به ماژول باعث شود تا نرم افزار بارگذاری مجدد شود. سوء استفاده مکرر از این آسیب پذیری منجر به ایجاد یک حمله انکار سرویس در نرم افزار می شود.FWSM نسخه های ۳٫۱، ۳٫۲، ۴٫۰ و ۴٫۱ تحت تاثیر این آسیب پذیر قرار دارند.

پس حتی اگه به جای زن ، سیسکو هم دارید ، هواستون رو جمع کنید … :دی

DHCP و پیاده سازی DHCP بر روی روتر و سویچ سیسکو

DHCP و پیاده سازی DHCP بر روی روتر و سویچ سیسکو

DHCP یکی از پر کاربرد ترین سرویس های شبکه است که در خفا و پس ضمینه مسئول اختصاص آدرس های IP به کلاینت های شبکه است ، این سرویس جزء لاینفک شبکه های بزرگ کوچک بوده و از ابتدایی ترین تراکنش های ارتباطی در شبکه های LAN است .

هنگامی که شما یک کلاینت را به یک شبکه مرتبط میکنید و یا با یک سرور PPP ارتباط برقرار میکنید ، پس از احراز هویت ، دریافت آدرس IP از ابتدایی ترین واکنش هاست .

استفاده از DHCP علاوه بر افزایش کارایی شبکه به افزایش چشمگیر امنیت در شبکه های مبتنی بر سیسکو می انجامد .

بدین ترتیب که به عنوان یک مدیر شبکه امکان مدیریت و رصد مشکلات به سادگی امکان پزیر است ، و همچنین از مشکلاتی نظیر IP Conflict و دسترسی غیر مجاز به آدرس های IP جلوگیری به عمل می آید .

پیاده سازی DHCP بر روی روتر ها و سویچ های سیسکو به سادگی امکان پذیر بوده و ترافیک و لود چندانی را به دستگاه تحمیل نمینماید .

شروع کار :

توصیه میشود ، ابتدا یک دیتابیس برای نگهداری واگذاری آدرس های IP ایجاد و دسترسی FTP به آن را میسر نمایید :

Router(config)# ip dhcp database ftp://user:[email protected]/router-dhcp timeout 80

جلوگیری از اعطای آدرس های 100 تا 103 :

Router(config)# ip dhcp excluded-address 172.16.1.100 172.16.1.103

Router(config)# ip dhcp pool 1
Router(dhcp-config)# utilization mark high 80 log
Router(dhcp-config)# network 172.16.0.0 /16
Router(dhcp-config)# domain-name shabake.ir #domain name
Router(dhcp-config)# dns server 217.218.127.127 217.218.155.155 #dci dns servers
Router(dhcp-config)# default-router 172.16.1.100 172.16.1.101 #this is the Gateway address
Router(dhcp-config)# option 19 hex 01 #additional dhcp option code for example tftp address
Router(dhcp-config)# lease 30 # the lease amount

بدین ترتیب امکان استفاده از امکانات DHCP بر روی روتر و سویچ های سیسکو میسر میگردد ،، البته امکانات پیشرفته تری نیز وجود داره ، که در صورت نیاز میتوانید از آنها استفاده کنید ،، لازم به توضیح است ، استفاده از سرویس DHCP بر روی شبکه های VLAN که دارای Access Switch و Core Switch هستند ، بر روی سویچ های لایه دسترسی توصیه میشود .

اگر به هر دلیلی مایل به استفاده از دیتابیس جهت ثبت واگذاری IP نبودید میتوانید از این کامند استفاده نمایید :

Router(config)# no ip dhcp conflict logging

بررسی:

توسط این دستور میتوانید میزان استفاده از منابع IP را مشاهده کنید :

Router(config)# ip dhcp use class

 

 وفقک الله
Aka Networks
 

پیاده سازی Static NAT بر روی روتر سیسکو

Static nat

پیاده سازی Static NAT بر روی روتر سیسکو

پیاده سازی Static NAT شاید یکی از پر کاربرد ترین و ساده ترین سناریو های مورد استفاده باشد .

با توجه به محدودیت میزان منابع IP در بعضی موارد ما ملزم به استفاده از Network Address Translation و یا همان NAT هستیم

بدین ترتیب که درخواست های ارسالی از شبکه داخلی با IP های خصوصی و نامعتبر را به یک یا چند Valid IP اجتصاص میدهیم .

برای مثال ما یک شبکه با 100 کلاینت و یک عدد Valid IP جهت دسترسی به اینترنت در اختیار داریم

interface FastEthernet0/0
description NET
ip address 217.218.1.1 255.255.255.252
ip nat outside
ip virtual-reassembly in
end

و اینترفیس شبکه داخلی :

interface FastEthernet0/1
description Local Network
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
end

نیاز ما ایجاد دسترسی به اینترنت برای رنج 192.168.1.0/24 است :

Aka-Core-Router#conf t

Aka-Core-Router(config)#ip acce s nat

Aka-Core-Router(config-std-nacl)#per 192.168.1.1 0.0.0.255 رنج آدرس های مجاز برای دسترسی به نت

Aka-Core-Router(config)#:ip nat inside source list nat interface FastEthernet0/0 overload

Aka-Core-Router(config)#int fas 0/1 اینترفیس داخلی با آدرس های نا معتبر

Aka-Core-Router(config-if)#ip nat inside ترجمه آدرس ها بر روی اینترفیس داخلی

Aka-Core-Router(config)#int fas 0/0 اینترفیس خروجی با آدرس معتبر

Aka-Core-Router(config-if)#ip nat outside ترجمه آدرس ها روی اینترفیس خروجی

 بدین ترتیب هر کلاینت با تنظیم Gateway و DNS سرور امکان دسترسی به اینترنت را خواهد داشت .

 

Aka Networks

استفاده از روتر سیسکو به عنوان SIP Gateway

vg350

استفاده از روتر سیسکو به عنوان SIP Gateway

قطعا پیش اومده که لازم باشه در محیط های شبکه سیسکویی VOIP راه اندازی کنید ، از اونجایی که سیسکو و کلا شرکت های بزرگ علاقه مندن در رابطه با همه تکنولوژی ها پتنت خودشون رو داشته باشن ، در این ضمینه هم سیسکو پروتکل SCCP یا همون SKINNY رو معرفی میکنه که با Cisco Call Manager تشکیل یه مجموعه Unified Communications رو میده ، که البته مزایا و پیچیدگی ها و محدودیت ها و صد البته هزینه های خودش رو داره ..    برای مثال شما ملزم به خرید لایسنس Cisco Call Manager هستید که رقم های نجومی رو خدمتتون اعلام میکنند ! در مقابل دنیای Open Source و گزینه های مناسبی برای اسکیل های متوسط و کوچیک مثل Asterisk یکم انتخاب رو سخت میکنه .. الان نگارش های مختلفی از سیستم های Voice over IP بر پایه Asterisk وجود داره که اکثرا مجانی هستند و امکانات بسیار زیادی رو در اختیارتون میذارن و البته امکانات Develop بالا که باعث میشه ، سیستم های متوسط و رو به کوچک از اون استفاده کنه …

pvdm8

PVDM 8

VIC-4FXO

VIC-4FXO

2811+4fxo                                                     cisco 2811 + 4FXO

یه امکان دیگه ای که در روتر های سیسکو تعبیه شده ، سرویس PBX کوچک و سادیه به نام Cisco Call Manager Express که بسته به مدل روتر و ورژن IOS تعداد Extension های بیشتری رو ساپورت میکنه ، که البته خیلی امکانات محدودی در مقایسه با خود سیسکو کال مینیجر در اختیارتون قرار میده ، ولی من به شخصه دوران خوبی باهاش داشتم سالها پیش ! خب ، بحث اینجا بود که بعضی افراد در یک شبکه مبتنی بر سیسکو میخوان VOIP داشته باشن و ترجیح میدن از سیسکو نه به عنوان Call Manager و PBX بلکه به عنوان Voice Gateway استفاده کنند به هزاران دلیل … مثلا من به شما اکیدا توصیه میکنم با توجه به اینکه Tenor کیفیت بی رقیبی داره ، شما از هر برنده دیگه ای در ایران استفاده کنید الا تنور .. چرا هم نداره ، توصیه خطیریه ! ما اینجا میخوایم یه نمونه کانفیگ یه روتر 2811 با یه ماژول High WIC چهار پورت و8 PVDM یا همون DSP خودمون رو برسی کنیم .

یک راست میریم سروقت تنظیمات ارتباط با SIP سرور :

sip-ua keepalive target ipv4:x.x.x.x(Asterisk IP Address) keepalive trigger 1 authentication username 1000 password 7 15435sfsdfdsgdf8748 retry invite 2 retry response 2 retry bye 3 retry cancel 3 retry register 3 retry keepalive 3 registrar ipv4:x.x.x.x expires 3600 sip-server ipv4:x.x.x.x(Asterisk IP Address)

حالا rule های ارتباطات ورودی به استریسک :

dial-peer voice 1 voip destination-pattern 7777 session protocol sipv2 session target ipv4:x.x.x.x(Asterisk IP Address) session transport udp dtmf-relay rtp-nte codec g711ulaw no vad authentication username 1000 password 7 sdfasdfasdf54654

7777 اکستنشنیه که کال ورودی رو به استریسک سیمولیت میکنه ، این داخلی میتونه متفاوت باشه … حالا Dial Rule برای تماس های خارجی مثلا شهری 8 شماره ای :

dial-peer voice 1 pots description Shahri destination-pattern [2-8]T بدین معنی که از 2 تا 8 شروع شه و بعد اعداد 0تا 9 به تعداد 8 عدد port 0/0/0 پورت خروجی که باید برای هر چهار پورت این رول نوشته شه forward-digits 8

و حالا تنظیم یکی از پورت ها :

voice-port 0/0/0 no non-linear no vad timeouts call-disconnect 3 connection plar opx 7777 تماس وروردی impedance 600c آمپدانس خطوط ایران caller-id enable

خب تقریبا همین ، و بعد شما هفت جد و آبادتون رو یاد میکنید و میرید سراغ یه GW ساده تر … این فقط یه نمونه کانفیگ کامل بود که احتیاج به Tune دقیق داره و الا به کلی مشکل از قبیل قطع نکردن خطوط ، اشغالی ، بازگشت صدا ، نویز و و و … بر میخورید …      

   وفقک الله

Aka Networks