بایگانی برچسب: s

استفاده از روتر سیسکو به عنوان SIP Gateway

vg350

استفاده از روتر سیسکو به عنوان SIP Gateway

قطعا پیش اومده که لازم باشه در محیط های شبکه سیسکویی VOIP راه اندازی کنید ، از اونجایی که سیسکو و کلا شرکت های بزرگ علاقه مندن در رابطه با همه تکنولوژی ها پتنت خودشون رو داشته باشن ، در این ضمینه هم سیسکو پروتکل SCCP یا همون SKINNY رو معرفی میکنه که با Cisco Call Manager تشکیل یه مجموعه Unified Communications رو میده ، که البته مزایا و پیچیدگی ها و محدودیت ها و صد البته هزینه های خودش رو داره ..    برای مثال شما ملزم به خرید لایسنس Cisco Call Manager هستید که رقم های نجومی رو خدمتتون اعلام میکنند ! در مقابل دنیای Open Source و گزینه های مناسبی برای اسکیل های متوسط و کوچیک مثل Asterisk یکم انتخاب رو سخت میکنه .. الان نگارش های مختلفی از سیستم های Voice over IP بر پایه Asterisk وجود داره که اکثرا مجانی هستند و امکانات بسیار زیادی رو در اختیارتون میذارن و البته امکانات Develop بالا که باعث میشه ، سیستم های متوسط و رو به کوچک از اون استفاده کنه …

pvdm8

PVDM 8

VIC-4FXO

VIC-4FXO

2811+4fxo                                                     cisco 2811 + 4FXO

یه امکان دیگه ای که در روتر های سیسکو تعبیه شده ، سرویس PBX کوچک و سادیه به نام Cisco Call Manager Express که بسته به مدل روتر و ورژن IOS تعداد Extension های بیشتری رو ساپورت میکنه ، که البته خیلی امکانات محدودی در مقایسه با خود سیسکو کال مینیجر در اختیارتون قرار میده ، ولی من به شخصه دوران خوبی باهاش داشتم سالها پیش ! خب ، بحث اینجا بود که بعضی افراد در یک شبکه مبتنی بر سیسکو میخوان VOIP داشته باشن و ترجیح میدن از سیسکو نه به عنوان Call Manager و PBX بلکه به عنوان Voice Gateway استفاده کنند به هزاران دلیل … مثلا من به شما اکیدا توصیه میکنم با توجه به اینکه Tenor کیفیت بی رقیبی داره ، شما از هر برنده دیگه ای در ایران استفاده کنید الا تنور .. چرا هم نداره ، توصیه خطیریه ! ما اینجا میخوایم یه نمونه کانفیگ یه روتر 2811 با یه ماژول High WIC چهار پورت و8 PVDM یا همون DSP خودمون رو برسی کنیم .

یک راست میریم سروقت تنظیمات ارتباط با SIP سرور :

sip-ua keepalive target ipv4:x.x.x.x(Asterisk IP Address) keepalive trigger 1 authentication username 1000 password 7 15435sfsdfdsgdf8748 retry invite 2 retry response 2 retry bye 3 retry cancel 3 retry register 3 retry keepalive 3 registrar ipv4:x.x.x.x expires 3600 sip-server ipv4:x.x.x.x(Asterisk IP Address)

حالا rule های ارتباطات ورودی به استریسک :

dial-peer voice 1 voip destination-pattern 7777 session protocol sipv2 session target ipv4:x.x.x.x(Asterisk IP Address) session transport udp dtmf-relay rtp-nte codec g711ulaw no vad authentication username 1000 password 7 sdfasdfasdf54654

7777 اکستنشنیه که کال ورودی رو به استریسک سیمولیت میکنه ، این داخلی میتونه متفاوت باشه … حالا Dial Rule برای تماس های خارجی مثلا شهری 8 شماره ای :

dial-peer voice 1 pots description Shahri destination-pattern [2-8]T بدین معنی که از 2 تا 8 شروع شه و بعد اعداد 0تا 9 به تعداد 8 عدد port 0/0/0 پورت خروجی که باید برای هر چهار پورت این رول نوشته شه forward-digits 8

و حالا تنظیم یکی از پورت ها :

voice-port 0/0/0 no non-linear no vad timeouts call-disconnect 3 connection plar opx 7777 تماس وروردی impedance 600c آمپدانس خطوط ایران caller-id enable

خب تقریبا همین ، و بعد شما هفت جد و آبادتون رو یاد میکنید و میرید سراغ یه GW ساده تر … این فقط یه نمونه کانفیگ کامل بود که احتیاج به Tune دقیق داره و الا به کلی مشکل از قبیل قطع نکردن خطوط ، اشغالی ، بازگشت صدا ، نویز و و و … بر میخورید …      

   وفقک الله

Aka Networks  

ایمن سازی روتر سیسکو – Secure Cisco Router

روتر سیسکو امنیت روتر سیسکو

ایمن سازی روتر سیسکو

حالا که بحث امنیت روتر پیش امده ، بد نیست یک چند نکته را هم مد نظر داشته باشیم ،

چون خود روتر میتواند یک هدف خوب برای انواع حملات باشد ، به شکلی که اگر کسی مثلا مسریاب مرزی شما رو High Load کند ، عبور ترافیک به مشکل بر خورده و شبکه شما در ارتباط با اینترنت فلج میشود ، لذا ، چند نکته که استفاده از آنها ما را به حداقل امنیت میرساند را باید رعایت کنیم .

1 – پورت های خطرناک را ببندید :

130 deny tcp any any range 135 140 (497235 matches)
140 deny udp any any range 135 140 (8303931 matches)
150 deny tcp any any eq 445 (24650346 matches)
160 deny tcp any any eq 449 (11 matches)
170 deny tcp any any eq daytime (39 matches)
180 deny tcp any any range 27000 27020 (6547 matches)
190 deny udp any any range 27000 27020 (290 matches)
200 deny tcp any any range 1024 1030 (24568 matches)
210 deny tcp any any range 1363 1380 (174634 matches)
220 deny udp any any eq 11751 (23 matches)
230 deny tcp any any eq 11751 (441 matches)
240 deny udp any any eq 1434 (10814 matches)
250 deny tcp any any eq 1433 (536911 matches)
260 deny udp any any eq 1433 (193 matches)
270 deny tcp any any eq 1434 (9133 matches)
280 deny tcp any any eq 554 (191 matches)
290 deny tcp any any eq 7070 (225 matches)
300 deny tcp any any eq 2773 (5923 matches)
310 deny tcp any any eq 54283 (590 matches)
320 deny udp any any eq echo (812 matches)
330 deny tcp any any eq echo (44 matches)
340 deny tcp any any eq discard (44 matches)
350 deny udp any any eq 554 (204 matches)
360 deny udp any any eq 7070 (8 matches)
370 deny tcp any any eq 8866 (261 matches)
380 deny tcp any any eq 9898 (230 matches)
390 deny tcp any any eq 10000 (271 matches)
400 deny tcp any any eq 10080 (1031 matches)
410 deny tcp any any eq 12345 (432 matches)
420 deny tcp any any eq 17300 (221 matches)
430 deny tcp any any eq 8554 (255 matches)
440 deny udp any any eq 8554 (8 matches)
450 deny udp any any eq 4444 (90 matches)
460 deny tcp any any eq 4444 (3850 matches)
470 deny tcp any any eq 5554 (369 matches)
480 deny udp any any eq 1500 (173 matches)
490 deny tcp any any eq 1919 (8152 matches)
500 deny tcp any any eq 2967 (5250 matches)
510 deny udp any any eq 2967 (101 matches)
520 deny tcp any any eq 1425 (10084 matches)
530 deny tcp any any eq 6667 (18607 matches)
540 deny tcp any any eq 8943 (221 matches)
550 deny tcp any any eq 4662 (3630 matches)
560 deny tcp any any eq 1034 (2946 matches)
570 deny tcp any any eq 81 (9123 matches)
580 deny tcp any any eq 8181 (420 matches)
590 deny tcp any any eq 2339 (6884 matches)
600 deny tcp any any eq 31337 (331 matches)
610 deny tcp any any eq 2745 (6134 matches)
620 deny tcp any any eq 37 (39 matches)
630 deny tcp any any eq 1500 (9704 matches)
640 deny tcp any any eq 1501 (9367 matches)
650 deny tcp any any eq 1502 (9473 matches)
660 deny tcp any any eq 1503 (9126 matches)
670 deny udp any any eq 1501 (160 matches)
680 deny udp any any eq 1502 (258 matches)
690 deny udp any any eq 1503 (168 matches)
700 deny tcp any any eq 1214 (11340 matches)
710 deny udp any any eq 65506 (326 matches)
720 deny udp any any eq 3410 (158 matches)
730 deny udp any any eq 3128 (148 matches)
740 deny udp any any eq 3127 (202 matches)
750 deny udp any any eq 8080 (207 matches)
760 deny udp any any eq 1111 (408 matches)
770 deny udp any any eq 8998 (9 matches)
780 deny udp any any eq 27374 (51 matches)
790 deny udp any any eq 1214 (107 matches)
800 deny udp any any eq 9999 (36 matches)
810 deny udp any any eq tftp
820 deny udp any any eq 2745 (208 matches)
830 deny tcp any any eq 1080 (10329 matches)
850 deny tcp any any eq sunrpc (42 matches)
860 deny tcp any any eq nntp (46 matches)
870 deny tcp any any eq drip (4244 matches)
880 deny tcp any any eq exec (1 match)
890 deny udp any any eq rip (1 match)
900 deny udp any any eq ntp (58094 matches)
910 deny tcp any any eq 2283 (6850 matches)
920 deny tcp any any eq 2535 (6262 matches)
930 deny udp any any eq 1026 (1711 matches)
940 permit ip any any (864701348 matches)
950 permit icmp any any

لازم است یک ACL با سیاست خودتان و مثلا پورت های عمومی خطرآفرین تهیه ، و انرا روی اینترفیس ورودی اعمال کنید.

conf t
int gig0/0
ip acce firewall in
ip acce firewall out

2 – باز هم توصیه میشود ، دسترسی Telnet را با SSH خایگزین کنید ، یا حداقل پورت telnet را بر طبق مقاله قبل عوض کنید.

 

تعویض پورت تلنت

 

3 – آدرس های عمومی را در درگاه وروردی اینترنت جهت جلوگیری از Spoofing ببندید و یک نکته حرفه ای اینکه یک BGP Peering با شبکه team-cymru برقرار کنید و ورودی route ها را باز بگذارید ، این شرکت IP های BOGON را برای شما ارسال میکند و این لیست خود به خود آپدیت و جلوی route شما به این دسته از IP ها را میگیرد :

http://www.team-cymru.org/Services/Bogons/bgp.html

access-list 111 deny ip 127.0.0.0 0.255.255.255 any
access-list 111 deny ip 192.168.0.0 0.0.0.255 any
access-list 111 deny ip 172.16.0.0 0.0.255.255 any
access-list 111 deny ip 10.0.0.0 0.255.255.255 any
access-list 111 deny ip host 0.0.0.0 any
access-list 111 deny ip 224.0.0.0 31.255.255.255 any
access-list 111 deny icmp any any redirect

3 – دسترسی SNMP را یا ببندید ، یا محدود کنید :

no snmp-server or >
snmp-server community SnMp@@!!123 RO 197
ip acce e 197
permit udp “trusted host ips” host “router ip” eq snmp
deny ip any any

4 – به جای enable password از enable secret استفاده کنید و پسورها را hash کنید :

service password-encryption

enable secret 5 f68a7a14ff272beddf3a6a3d3632158b/

username amirkhosro privilege 15 secret 5 $f68a7a14ff272beddf3a6a3d3632158b$.

این باعث میشود که دسترسی به پسورد شما حتی اگر کسی فایل کانفیگ روتر را هم داشته باشد غیر ممکن شود ، چون MD5 مثلا یک الگریتم یک طرفه است !

5 – سرویس بازنگاری پسورد را غیر فعل کنید ،

بدین ترتیب اگر کسی دسترسی فیزیکی هم به روتر پیدا کند نمیتواند پسور شما را ریکاور کند !

Aka-Core-Router(config)#no service password-recovery
WARNING:
Executing this command will disable password recovery me
chanism.
Do not execute this command without another plan for
password recovery.

Are you sure you want to continue? [yes/no]:yes

6 – سرویس های بدرد شما نخور را disable کنید !

Disable Echo, Chargen and discard
no service tcp-small-servers
no service udp-small-servers

Disable finger
no service finger

Disable the httpd interface
no ip http server

Disable ntp (if you are not using it)
ntp disable

Disable source routing
no ip source-route

Disable Proxy Arp
no ip proxy-arp  روی تمامی اینترفیس ها

Disable ICMP redirects
interface gig0/0
no ip redirects    روی تمامی اینترفیس ها

Disable Multicast route Caching
interface gig0/0 (your external interface)
no ip mroute-cache   روی تمامی اینترفیس ها

Disable CDP
no cdp run

Disable direct broadcast (protect against Smurf attacks)
no ip directed-broadcast روی تمامی اینترفیس ها

7 – فقط IP های ست شده روی هر اینترفیس را مجاز کنید مثلا :

Aka-Core-Router#sh run int fastEthernet 0/1.300
Building configuration…

Current configuration : 281 bytes
!
interface FastEthernet0/1.300
description esfehan
encapsulation dot1Q 300
ip address 217.218.1.1 255.255.255.248
no ip redirects
no ip unreachables
no ip proxy-arp
end
Aka-Core-Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Aka-Core-Router(config)#ip acce e 130
Aka-Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.7 an
Aka-Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.7 any
Aka-Core-Router(config-ext-nacl)#per icmp any any
Aka-Core-Router(config-ext-nacl)#deny ip any any
Aka-Core-Router(config-ext-nacl)#exit
Aka-Core-Router(config)#int fas 0/1.300
Aka-Core-Router(config-subif)#ip acce 130 in

و صد البته روی اینترفیس خروجی ، فقط IP های شناخته شده شبکه خودتان را اجازه ترانزیت ترافیک بدهید

مثلا شما یک کلاس /24 دارید 217.218.1.0/24 :

Aka-Core-Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Aka-Core-Router(config)#ip acce e 131
Aka-Core-Router(config-ext-nacl)#per ip 217.218.1.0 0.0.0.255 any
Aka-Core-Router(config-ext-nacl)#per ip any 217.218.1.0 0.0.0.255
Aka-Core-Router(config-ext-nacl)#per icmp any any
Aka-Core-Router(config-ext-nacl)#deny ip any any
Aka-Core-Router(config-ext-nacl)#exit
Aka-Core-Router(config)#int gig 0/0 ( outside interface )
ip acce 131 in
ip acce 131 out

8 – همه چیز را لاگ کنید :

logging trap debugging
logging 192.168.1.10

البته خیلی راه ها وجود دارد برای افزایش امنیت یک مسیریاب ، مثلا کنترل منابع در control-plane و و و …

این نکات همانطور که در ابتدا اشاره شد ، حداقل کارهایی است که میبایست برای امنیت مسیریاب انجام دهید و صد البته همین نکات را به این شسته رفتگی در هیچ منبعی پیدا نخواهید کرد 😉

همیشه بدانید ، ارزش یک روتر سیسکو ، از جان شما بیشتر است و امنیتش از جان همسرتان …

 

وفقک الله
Aka Networks

router family

میزان کارایی روتر های سیسکو ( Cisco Routers Performance )

کارایی روتر سیسکو

کارایی روتر سیسکو

 میزان کارایی روترهای سیسکو ( Cisco Routers Performance )

گاها پیش آمده که از شما به عنوان یک مهندس شبکه سوال شده که مثلا من برای X مقدار پهنای باند ، باید از چه مدل روتری استفاده کنم و یه چه مدل سویچ جوابگوی فلان میزان پهنای باند است ؟!

البته که این سوال از پایه اشتباه است ، چون میزان پهنای باند نمیتواند مکیال و معیار مناسبی برای برسی قدرت یک دیوایس سویچینگ یا مسیریابی باشد .

برای مثال ، شما یک مسیریاب که با سرعت 100 مگابیت به اینترنت متصل است در سر راه دارید و شما از سایت مایکروسافت با سرعت 100 مگابیت اقدام به دانلود میکنید ، اگر میزان لود CPU روتر را برسی کنید ، میبینید که مثلا در یک روتر 2811 ، 20% یوتلایز دارید ، که شاید باعث تعجب بعضی و یا باعث اشتباه در نظر دهی بعدی شود .

میزان پکت ها ، سایز پکت ها ، پروتکل های موجود و استراکچر ها و نوع سرویس های ران شده روی دیوایس ، طرح کننده نیاز شماست …

برای مثال ممکن است یک مسیریاب 1841 سیسکو با 1000 پکت 64 کیلوبایتی ، OVERLOAD شود !

سرویس هایی مثل پکت اسنیفینگ ،  Firewall ، Policy Routing ، ACL ، IP Audit , Nat و … سرویس هایی عمومی است که باعث افزایش لود مسیریاب میشود ، طبق یک قانون کلی اگر مسیریاب شما هیچ استراکچر خاصی را اجرا نمیکند و فقط یک استاتیک روت روی آن تعریف کردید ، هر چه سایز پکت ها کوچکتر و تعداد آنها بیشتر شود ، میزان لود بالاتری میطلبد !

در ذیل مطلب به چند عدد کلی اعلام شده از طرف شرکت سیسکو در مورد مسیریاب های معروف که در محیط آزمایشگاهی با پکت های 64 کیلوباتی و فقط سرویس IP ، میپردازیم .

نکته : CEF بر روی مسیریاب در حال اجراست .

2 Mb/s4000 PPSCisco160X
7.5 Mb/s15000 PPSCisco 2611
61 Mb/s120000 PPSCisco 2811
87 Mb/s170000 PPSCisco 2821
180 Mb/s353000 PPSCisco 2911
296 Mb/s580000 PPSCisco 2951
100 Mb/s250000 PPSCisco 3745
256 Mb/s500000 PPSCisco 3845
500 Mb/s982000 PPSCisco 3945
1 Gb/s2000000 PPS7206 G2

در آخر باید به این مطلب اشاره کنم که ، حتما سعی کنید  برآوردهای خود از نیاز های شبکه به یک دیوایس را حداقل 30% بالاتر با نرخ رشد مناسب ارزیابی کنید و همیشه اعداد جدول بالا را 50% اغراق آمیز در نظر بگیرید!

وفقک الله …