بایگانی نویسنده: امیرخسرو احمدی

درباره امیرخسرو احمدی

about.me/amirkhosro

روتر سیسکو ۷۶۰۹

فروش روتر سیسکو 7609

روتر سیسکو 7609

روتر سیسکو 7609

فروش روتر سیسکو 7609

 7609-S معرفی و بررسی روتر سیسکو سری

روتر سیسکو 7609 سری S یا به اختصار Cisco 7609-S سری ویژه ای از روتر های 7609 است که با قابلیت های بالا و کارایی بسیار قوی ، اصولا در Edge شبکه های بزرگ قرار میگرد ، جایی که کیفیت سرویس ، سرویس های IP Base همچنین Redundancy و تحمل خرابی یا همان Fault Tolerance از اهمیت بسزایی برخوردار است .

روتر سیسکو 7609s این امکان را به سرویس پروایدر ها میدهد که بتوانند خدمات مببتی بر IP و شبکه های بزرگ Ethernet را بر اساس ساختاری پیشرفته و قوی ، برای ارائه سرویس های حساس و برخط ، نظیر Voice – Video , data ، در انواع کاربری ها ، بنا کنند .

روتر سیسکو 7609 به سازمان ها و تشکیلات بزرگ قابلیت ارائه خدمات و سرویس های پیشرفته WAN و MAN با ترافیک سنگین پکت و حساسیت بسیار بالا را ارائه داده و خیال سازمان ها و Enterprise ها را از مشکلات مربوط به محدودیت های سرعت ، High Load و همچنین مشکلات Out of Service که به خاطر خرابی تجهیزات پیش می آید را ،، آسوده نماید .

روتر سیسکو 7609 ترکیب هنرمندانه ای از سرعت و قابلیت در کنار اطمینان پذیری بالاست ،، روتر سیسکو 7609 با دارا بودن 9 اسلات توسعه قابلیت های بالایی در افزایش کارایی و انتخاب نوع استفاده به طراحان شبکه میدهد . برای مثال میتوان از روتر سیسکو 7609 به عنوان WAN Aggregator ، یا Peering Router ، به عنوان Broadband RAS و یا به عنوان روتر اصلی در شبکه های Metro Ethernet در نقش  UP Link Router بهره جست .

روتر سیسکو 7609 با دارا بودن تروپوت بسیار بالای 400Mpps و یا 720Gbps پاسخگوی نیاز سرویس پروایدر ها ، FCP ها و تمامی مراکزی که با توجه به افزایش سرعت اینترنت و شبکه ای سازمانی ، نیازمند روتر با سرعت و کیفیت بالا و قابلیت اطمینان پذیری بالا هستید ، باشد .
روتر سیسکو 7609 ، به لطف پشتیبانی از چندین Route Processor و Redundant Power Supply خیال شما را از بابت مشکلات مربوط به خرابی که منتج به قطع سرویس خواهد شد ، آسوده خواهد کرد ، کما اینکه با استفاده از پردازنده اضافی میتوان از قدرت پردازشی بالاتری نیز بهره جست .

روتر سیسکو 7609 قابلیت استفاده از SUP720 مورد استفاده در سویچ های 6500 و همچنین سری جدید RSP720 به همراه Multi Layer Switch Feature Card – MSFC-4 که در روتر سیسکو 7609 مورد استفاده قرار میگیرد را داراست که با داشتن 2 عدد 10Gb Uplink در استفاده از Line card های برای اضافه نمودن پورت های Uplink 10Gb صرفه جویی مینماید . که در صورت استفاده به شکل Dual Route Processor امکان استفاده از 4 پورت 10Gb مهیا میگردد .

سوپروایزر انجین 720

سوپروایزر انجین 720

rsp720-3cxl-ge

rsp720-3cxl-ge

از نکات برجسته شاسی 9 اسلاته روتر سیسکو سری 7609 میتوان به موارد زیر اشاره نمود :

  • مکانیسم بهبود یافته رفع خرابی که در زمان کمتر از 100ms انجام میشود . ( در صورت استفاده از تجهیزات ریداندنت ، نظیر Dual RSP و Dual Power )
  • قابلیت ارائه توان تا 750W در هر اسلات .
  • ماژول فن های اضافی که قابلیت گردش هوا را در 5 سرعت مختلف مهیا می نمایند .
  • بهبود امکان تهویه هوا و اندازه گیری و پایش حرارتی شاسی و روتر و همچنین مدیریت و مانیتورینگ.

همچنین روتر سیسکو 7609 امکان پشتیبانی ار پاور ساپلای های AC و DC در توان های 4000 و 6000 وات و همچنین 3000َAC را داراست .

ws-cac-6000

ws-cac-6000

روتر سیسکو 7609 با قابلیت پشتیبانی از Shared port adaptors یا همان SPA که از تکنولوژی i-Flex سیسکو بهره مند میشوند ، امکان تلفیق سرعت و قدرت پردازشی بالا را در کنار SPA Interface Processors فراهم می آورد ، بدین ترتیب که توسط خیل کثیری از اداپتور های SPA امکان ارائه سرویس های متنوع بر روی بستر های متنوع و سرعت های مختلف از OC-3 تا OC-192 و از Fast Ethernet تا 10 Gigabit Ethernet با توان پردازشی بالا و استفاده از امکانات SIP های مختلف ، وجود دارد .

sip-400

sip-400

sip-600

sip-600

از دیگر قابلبت های مهم روتر سیسکو 7609 ، پشتیبانی از تکنولوژی FlexWAN و ماژول های FlexWAN است ، بدین ترتیب که امکان استفاده از ماژول های روتر های قدیمی تز سری 7200 و 7500 برای برقراری ارتباطات WAN از سرعت DS-0 تا OC-3 مقدور خواهد بود .

با توضیحات بالا ، روتر سیسکو 7609 به کمک پورت های SPA بر روی SIP ها و همچنین ماژول های FlexWAN ، روتر سیسکو 7609 تبدیل به بهترین گزینه برای ترمینیت کردن ارتباطات WAN بر روی بستر های مختلف و سرعت های مختلف خواهد بود که این خود برای بسیاری از سرویس پروایدر ها و سازمان ها ایدال است .

روتر سیسکو 7609 با شاسی ارائه میشود که قابلیت پشتیبانی از طیف وسیعی از Line Card ها با استفاده های متفاوت را داراست ، از جمله میتوان به گزینه های زیر اشاره نمود :

  • SPAs and SIPs : SIP-200 , SIP-400 , SIP-600

Channelized T1/E1 – T3 and OC-3/STM-1
OC-3/STM-1 , OC-12/STM-4 , OC-48/STM-16 , OC-192/STM-64
Fast Ethernet , Gigabit Ethernet , 10 Gigabit Ethernet

  • Enhanced FlexWAN module , support from DS-0 to OC-3 for channelized and ATM and also FE
  • High-density Ethernet service modules : 10/100Mbs , Gigabit Ethernet and 10 Gigabit
  • Service modules : IP Security ( IPsec ) , Firewall , distributed dental of service , IDS , network analysis , content switching

روتر سیسکو 7609 قابلیت پشتیبانی از سوپروایزر های زیر را داراست :

  • Cisco Route Switch Processor 720  ( RSP720-3C-GE and RSP720-3CXL-GE )
  • Cisco Route Switch Processor 720-10GE  ( RSP720-3C-10GE and RSP720-3CXL-10GE )
  • Cisco Catalyst 6500 Supervisor Engine 32 (WS-SUP32-GE-3B and WS-SUP32-10GE-3B)
  • Cisco Catalyst 6500 Supervisor Engine 720 (WS-SUP720-GE-3B and WS-SUP720-3BXL)

مشخصات فنی روتر سیسکو 7609 به نقل از سایت سیسکو :

Feature Summary
Cisco 7609-S Chassis Features
• Twenty-one rack units (RUs) (36.75 in. [93.3 cm]) high, up to 2 chassis per 7-foot rack
• Nine configurable interface slots
• Route processor, switch fabric, and power supply protection capability: 1 + 1
• Tiered-speed fan design (standard): 1 + 1
• Cable management tray options for fiber and coaxial and dense 10/100 cable configurations
• Single-side connection management for both interface and power terminations
• Front-to-back airflow
Cisco 7609-S System Features
• Total throughput: 720 Gbps
• Up to 400-Mpps distributed forward rate (requires distributed forwarding cards [DFCs])
Cisco 7609-S Technical Specifications
• Nine-slot chassis
• Network Equipment Building Standards (NEBS) Level 3 compliance
• Dimensions (H x W x D): 36.75 x 17.2 x 20.7 in. (93.3 x 43.1 x 53.3 cm)
• Power requirements:
– -208 to 240 VAC (recommended)
– -48 to -60 VDC (4000 WAC supplies require 30A input circuits)
• Weight: 121 lb (54.9 kg; chassis only); 270 lb (122.5 kg; full configuration)
• Predicted Mean time between failure (MTBF): 448,000 hours
• Environmental conditions:
– Operating temperature: 32 to 104°F (0 to 40°C)
– Storage temperature: -4 to 149°F (-20 to 65°C)
– Relative humidity, operating: 10 to 85%, noncondensing
– Relative humidity, storage: 5 to 95%, noncondensing
– Operating altitude: -500 to 6500 ft
• Minimum software release: Cisco IOS Software Release 12.2(18)SXE

روتر سیسکو 7609 مناسب چه استفاده هایی است ؟

روتر سیسکو 7609 ایدال برای مجموعه های پر مصرف ، نظیر سازمان ها و وزارت خانه ها و شرکت های بزرگ با پهنای باند بالا و یا ترافیک شبکه بالا ، ارتباطات WAN متعدد با استفاده از تکنولوژی های مختلف ، نظیر MPLS – ATM – Interanet – SDH – Leased Line – Metro Ethernet است که بانک ها و موسسات با شعبات متعدد از جمله مشتریکن پر مصرفی هستند که قطعا نیازمند روتری مرزی با قابلیت اطمینان پذیری بالا و همچنین توان پردازشی و هندل ترافیک سنگین که flexible بودن در انواع ارتباطات و پشتیبانی از انواع تکنولوژی های ارتباطی قدیمی و جدید ، به لحاظ انطباق با شبکه های قدیمی و جدید را دارا باشد .

سرویس پروایدر ها ، یکی از اصلی ترین مشتریان این روتر ارزشمند سیسکو هستند ،، با توجه به افزایش نیاز به ارتباطات پر سرعت و تنوع ارتباطاتی و حساسیت صوت و تصویر بر تاخیر و اختلالات و قطعی های غیر مترقبه که به لحاظ مشکلات سخت افزاری و عدم وجود منابع کافی روتینگ / سویچینگی ،، روتر سیسکو ۷۶۰۹ بهترین انتخاب با توجه به صرفه اقتصادی در مقابل ارش فنی می باشد .

روتر سیسکو ۷۶۰۹ به عنوان روتر مرزی ( Edge Router ) ، همسو کننده ارتباطات راه دور Wan Aggregator , BGP Peering Router , Cariier Router , Metro Ethernet  و … میتواند به راحتی ماموریت خویش را با موفقیت و کیفیت به انجام برساند ، بر همگان کیفیت دیوایس های سیسکو فاش است ، بنابراین با توجه به پشتیبانی روتر سیسکو 7609s از ماژول های جدید و پرسرعت ، میتوان انتظار داشت تا سال ها ، به عنوان عضو بی بدیل شبکه ، نقش خود را ایفا نماید . سیسکو روتر ۷۶۰۹ را تا سال ۲۰۲۱ پشتیبانی خواهد کرد .

خرید روتر سیسکو 7609

در صورتی که متقاعد شدید که نیاز به این روتر ارزشمند جهت استفاده در شبکه خود دارید ، میتوانید به قیمتی بسیار مناسب و با گارانتی و پشتیبانی معتبر ظرف مدت کمتر از ۷ روز ، روتر سیسکو ۷۶۰۹ را در ایران تحویل بگیرید .

جهت مشاوره رایگان و کسب اطلاعات بیشتر در رابطه با خرید روتر سیسکو 7609 لطفا تماس بگیرید :

0912-1308444       021-88948999     [email protected]

سیسکو Netflow

سیسکو NetFlow : کانفیگ NetFlow توسط روتر سیسکو

سیسکو NetFlow : کانفیگ NetFlow توسط روتر سیسکو

راه اندازی سیسکو NetFlow بر روی روتر سیسکو

سیسکو NetFlow یکی از پروتکل های اختصاصی سیسکو Cisco Proprietary protocols ست ،  که سیسکو آنرا جهت مانیتورینگ ، ترابل شوتینگ یا همان عیب یابی و رفع عیب و همچنین جهت بدست آوردن داده های آماری در رابطه با ترافیک شبکه ، توسعه و مورد توجه قرار داده است .

سیسکو NetFlow یکی از ابزار های گران مایه جهت بررسی و مشاهده و پیگیری مشکلات ، حملات ، نشت اطلاعات و … برای مدیران شبکه های سیسکو است ، بدین ترتیب که با بروز مشکلات احتمالی ، بررسی داده های آماری سیسکو NetFlow جزء ابتدایی ترین گام ها ، جهت حل مشکل است .

مشاهده Flow یا به بیانی جریان اطلاعات و پکت ها ، نوع آنها و منبع و مقصد و میزان ( ترافیک ) ، بیانگر بسیاری اطلاعات ارزشمند ، جهت مدیریت یک شبکه اطلاعاتی است ، زیرا پایش شبکه مستلزم بررسی مداوم و دقیق جریان اطلاعات عبوری از شبکه ، ( روتر ها – سوئیچ ها و … ) می باشد .

سیسکو NetFlow به شما میگوید که ترافیک به چه میزان ( پهنای باند – Bandwidth ) ، از کدامین مبدا ( Source IP ) توسط چه حاملی ( Protocol ) به چه مقصدی ( Destination IP ) و چه پورتی ، در جریان است ،، حتی در پیاده سازی های حرفه ای تر میتوان نوع Application و User Agent را نیز در نظر گرفت .

شعار سیسکو Net Flow : انجام موفقت آمیز ماموریت های حساسشامل بر سرویس ها و نرم افزار های حساس به کیفیت و پایداری خط ارتباطی به کمک سیسکو NetFlow !

توسط سیسکو NetFlow ، دیوایس سیسکو قابلیت بررسی و جمع آوری آمارهایی از این قبیل را خواهد داشت:

o   Source IP address
o   Destination IP address
o   Source port number
o   Destination port number
o   Layer-3 protocol type (ex., TCP, UDP)
o   ToS (type of service) byte
o   Input logical interface

پس از بررسی و نمونه گیری این اطلاعات در هر اینترفیس که NetFlow بر روی آن عملیاتی و فعال باشد ،، روتر و یا سوئیچ سیسکو بنا به تنظیمات قابلیت ارسال این اطلاعات آماری را به یک نرم افزار جمع آوری و تحلیل داده های آماری نت فالو یا NetFlow collector – NetFlow Analyzer که مسئول دریافت و دسته بندی و بررسی داده های بدست آمده از دیوایس سیسکو مربوطه است ،، بدین ترتیب امکان بررسی های بیشتر برای مدیران شبکه و مسئولین امنیت و اتاق کنترل NOC به راحتی فراهم می آید ،، در عین حال جهت افزایش بازدهی اقتصادی ،، مسئواین اقتصادی شبکه میتوانند با بررسی نمودار ها و تجمع ترافیک به یک مقصد و یا یک سرویس ،، تمهیدات لازم را جهت افزایش بهره وری اتخاذ کنند ،،
برای مثال کاربران یک شبکه ISP بزرگ ،، ترافیک عمده ای به سمت یک سایت ایرانی که در یکی از Data Center های ایرانی قرار داشته ، دارند ،،، مسئولین تجاری ISP پس از بررسی خروجی NetFlow ، متوجه Flow ترافیک به سمت این سرور در ISP دیگری میشوند و به منظور کاهش بار Gateway های اصلی که وظیفه تامین پهنای باند اینترنتی را دارند ،، با ISP مربوطه ، ارتباطی Point to Point برقرار کرده و ترافیک داخلی را از این طریق منتقل میکنند ،، که این خود باعث کاهش بار مالی ISP خواهد شد .

مزیت دیگر وجود Netflow در شبکه ،، بحث امنیتی و بررسی Attack ها و یا حملات محتمل است ،،
در زمان بروز یک حمله سایبری ،، تنها راه بررسی مدیران شبکه ،، بدست آوردن هدف در وهله اول و سپس دفع حمله می باشد ،، زیرا بدون داشتن امکانات بررسی ترافیک NetFlow ، بررسی جریان اطلاعات و هدف مورد حمله بسیار سخت و در بعضی موارد غیر ممکن مینماید .
لذا پیاده سازی صحیح سیسکو NetFlow و استفاده از یک سیستم Collector و Analysis دقیق به همراه نیروهای آموزش دیده مجرب و مانیتور دقیق و همیشگی جریان اطلاعات ،، نوع و میزان آن ،، قدم اول برای پایش شبکه ای مبتنی بر سیسکو است .

از دیگر مزایای چشم گیر و مهم پیاده سازی سیسکو NetFlow میتوان به امکانات بررسی شبکه ،، پس از انجام تغییرات جزئی یا کلی ، اظافه نمودن و یا تعویض و تغییر تجهیزات ،، تغییر و یا توسته Route ها و مسیر های و Media های ارتباطی ،، تغییرات در کانفیگ و پیاده سازی استراکچر های جدید و یا تغییر Routing Protocol ها Dynamic در شبکه است ،، بدین ترتیب که مثلا پس از اتصال به یک انشاب جدید اینترنتی ،، بررسی ترافیک عبوری و یا بررسی Prefix هایی که میبایست توسط BGP از یک مسیر خاص که به شکل عقلانی یا اقتصادی ، ارجح است ،، پرداخت .

مزایای Cisco NetFlow بیش از اینهاست ، لیکن در این مقال ما به اجمال به ماموریت های اصلی NetFlow که در ابتدای کار برای هر مدیر شبکه ای بسیار مورد توجه و کارگشا خواهد بود پرداختیم ،، و در ادامه به اختصار نحوه فعال سازی NetFlow بر روی روتر سیسکو و همچنین به معرفی تعدادی از نرم افزار های تحلیلی و جمع آوری اطلاعات آمار های NetFlow خواهیم پرداخت .

فعال سازی NetFlow بر روی روتر سیسکو

کانفیگ NetFlow

کانفیگ NetFlow  بر روی روتر سیسکو و سوئیچ سیسکو ،، به سادگی و سرعت امکان میپذیرد و پس از آن ، میبایست ارتباطی بین روتر سیسکو به عنوان NetFlow Sensor و یا جمع آور اطلاعات نت فالو ، برقرار نمود و خروجی اطلاعات آماری را توسط نرم افزار های مربوطه مشاهده و بررسی و تحلیل نمود.

ip flow-export destination x.x.x.x yyyy (Collector IP and port)
ip flow-export source <interface>
ip flow-export version 9 or 5
ip flow-cache timeout active 1
ip flow-cache timeout inactive 15
snmp-server ifindex persist

سپس فعال سازی سیسکو NetFlow بر روی هر اینترفیس لایه 3 .
ذکر این نکته هائز اهمیت است که اگر Netflow را هم بر ترافیک ingress و هم egress فعال کنید ، میزان پهنای باندی که نمایشداده میشود دو برابر خواهد شد و فاقد اعتبار است .

interface gig 0/1
ip flow ingress

نرم افزار های تحلیل اطلاعات سیسکو NetFlow

جهت جمع آوری و تحلیل و بررسی اطلاعات آماری سیسکو Netflow نرم افزار های رایگان و تجاری فراوانی موجود است ،، به عنوان مثال Solarwinds که یکی از شرکت های تولید کننده نرم افزار های مانیتورینگ شبکه است ، محصول NetFlow™ Traffic Analyzer را به شکل تجاری و ورژن سبک تر و RealTime آنرا به صورت مجانی عرضه مینماید . میتوانید نگارش رایگان آنرا از اینجا دریافت نمایید :
SolarWinds Realtime NetFlow Analyzer

SolarWinds Realtime NetFlow Analyzer

SolarWinds Realtime NetFlow Analyzer

شرکت Manage engine یکی از قوی ترین نرم افزار های Analyze خروجی Netflow را به شکل تجاری عرضه مینماید ،، برای اطلاعات بیشتر به سایت این شرکت مراجعه فرمایید : Manage Engine Netflow Analyzer .

NetFlow Analyzer

NetFlow Analyzer

برای مطالعه بیشتر در این زمینه ، میتوانید از منابع اصلی سیسکو NetFlow استفاده نمایید : دانلود PDF آموزش سیسکو Netflow

وفقک الله

سیسکو packet tracer

دریافت سیسکو Packet Tracer

دانلود سیسکو Packet Tracer

دانلود سیسکو Packet Tracer

دریافت سیسکو Packet Tracer

دریافت شبیه ساز سیسکو پکت تریسر

سیسکو Packet Tracer شبیه ساز اختصاصی سیسکو ، جهت امور آموزشی Cisco Academy و افرادی که علاقه مند به یادگیری سیسکو هستند لیکن دسترسی به دیوایس های گران قیمت سیسکو ، نظیر روتر های سیسکو و سوئیچ ها و فایروال های ASA و .. ندارند ،، یا در مواردی ، مدیران شبکه ، شمائی از شبکه زیر بار خود را در یک شبیه ساز ” Simulator ” ، مثل Cisco Packet Tracer پیاده سازی کرده ، و هر تغییر و بهینه سازی را ، قبل از تغییر در شبکه زنده ، بر روی شبیه ساز Cisco Packet Tracer اعمال و نتیجه را در یک محیط امن نظاره میکنند و پس از انواع تست ها ، آنرا در شبکه اصلی اعمال مینمایند .

سیسکو Packet Tracer یکی از اصلی ترین ابزار ها ، برای افرادیست که در تلاش برای دریافت مدارک سیسکو ، نظیر CCNA – CCNPCCIE , … هستند ، میباشد ،، چنانکه این افراد ملزم به ساعت ها تمرین عملی با دستگاه های سیسکو در محیط IOS ،، هستند ،، تا بتوانند توانایی های لازم عملی را در کانفیگ و راه اندازی دیوایس های سیسکو بدست آورند .

سیسکو Packet Tracer یکی از آسانترین شبیه سازهای شبکه های مبتنی بر سیسکو ست ،، شما میتوانید با نصب آن بر روی کامپیوتر شخصی خود ، سخت ترین استراکچر ها را به صورت Live پیاده سازی کرده و عملکرد یک شبکه بزرگ متشکل از انواع تکنولوژی های ارتباطی و انواع پروتکل های روتینگ و سوئیچینگ فعال را بررسی و نظاره کنید ،، در واقع بهترین راه برای بدست آوردن مهارت های لازم در سیسکو آکادمی ،، مطالعه و سپس تمرین تمرین و تمرین است .

صد البته ، هیچ چیز جای دیوایس حقیقی سیسکو رو نخواهد گرفت ،،، از دید اینجانب ،،، هیچ گاه تجربه کارکردن با یک سوئیچ سیسکو 3550 و یا روتر 2611 سیسکو همانند بهترین شبیه ساز ها نظیر سیسکو پکت تریسر نخواهد بود ، در واقع چلنج فیزیکی با یک دیوایس سیسکو ،، شنیدن صدای آن ،، دیدن حالت های مختلف LED های روی آن ،، استفاده از پورت ها و شکاف های توسعه و … خود بخش مهمی از آموزش است ،، شاید روزی برای انجام یک کار به یک سازمان مراجعه کنید ،، و مثلا قرار باشد یک روتر 3945 سیسکو را کانفیگ کنید ،، و آنگاه میبینید که در نگاه اول ، روتر سیسکو 3945 را نمی توانید بین روتر ها و سوئیچ های دیگر در رک تشخیص دهید ،، در حالی که بارها در شبیه ساز از آن استفاده کرده اید :دی !

در هر حال ، با وجود مزایای شبیه ساز Cisco Packet Tracer ، به همه دوستانی که در تلاش برای طی مدارج علمی در رشته سیسکو و شبکه هستند ، به شدت توصیه میشود که یک لابراتوار جمع و جور ، در حد حداقل های نیاز خود برای آموزش ، دست و پا کنید ،، برای مثال دانشجوهایی که برای CCNA مطالعه میکنند ، میتوانند با یک روتر سیسکو 2611 و یک سوئیچ سیسکو 2950 شروع کنند که جمع این دو دیوایس سیسکو را میتوان با قیمتی ناچیز تهیه کرد و آنگاه تجربه و کیفیت آموزش شما ، فطعا دوچندان خواهد شد .

افرادی که برای مدارک بالاتر ، مثل CCNP و CCIE مطالعه میکنند ، میتوانند با چند روتر سری 2600 سیسکو و چند روتر سیسکو 1841 و سوئیچ های کاتالیست 3560 و حتی سیسکو 3750 شروع کنند . البته تهیه لابراتوار برای مدارک امنیت نظیر CCSP و مدارک VOICE سیسکو CCVP و وایرلس نیازمند صرف هزینه های بسیار بالاتری خواهد بود ، چراکه فایروال های سری ASA سیسکو ، حتی دست دوم ، رقم بالایی را طلب میکند و یا تهیه IPPhone های سری 7900 و یا یک VOICE Gateway به همراه ماژول ها و PVDM ها ،، باعث سر به فلک کشیدن هزینه ها خواهد شد ، لیکن راه دیگری برای تجربه کارکرد یک سیستم VOIP ، جز در اختیار داشتن دستگاه های واقعی ، چه خرید چه اجاره رک ، وجود ندارد . اما نگران نباشید ، با انجام اولین پروژه ، تمامی هزینه های آموزشی جبران خواهد شد 😉

جهت دریافت شبیه ساز سیسکو Packet Tracer ورژن 6.2 ، اینجا کلیک کنید : Cisco Packet Tracer 6.2

فایل PDF آموزش سیسکو Packet tracer : آموزش پکت تریسر

وفقک الله

 

سیسکو IP Phone

ریست کردن IP Phone سیسکو

ریست کردن IP Phone سیسکو

ریست کردن IP Phone سیسکو

ریست کردن IP Phone سیسکو

آموزش Factory Default تلفن های سیسکو سری 7911G – 7940 – 7960 – 7942 – 7912

ریست کردن IP Phone سیسکو سری 7900 مدل های 7911 – 7912 – 7940 – 7941 – 7942 – 7960 – 7961 — 7962 , …. اکثرا شبیه به هم بوده و توسط کد دستوری در هنگام بوت شدن IP Phone سیسکو انجام می پذیرد .

ریست کردن IP Phone سیسکو ، معمولا زمانی که شما نیازمند تغییر Firmware و یا آپدیت / آپگرید آن و یا تبدیل IP phone سیسکو از پروتکل اختصاصی سیسکو SCCP به SIP هستید ، اتفاق می افتد .

IP Phone سیسکو به شکل پیشفرض معمولا با firmware اصلی که با پروتکل SIP هماهنگ است ، به فروش میرسد ، لذا در بعضی مدل های مخصوصا قدیمی تر ، اگر بخواهید IP Phone سیسکو را در شبکه VOIP مبتنی بر پروتکل SIP ، نظیر Asterisk Base ها ElastixFree PBX , … و یا 3CX که همگی VOIP PBX های  SIP Base هستند ، استفاده کنید ، ملزم به تغییر نرم افزار Firmware آن به ورژن SIP هستید که میبایست اقدام به Hard Restart و FirmWare Erase تلفن سیسکو نمایید .

در این نوشتار روش ریست کردن IP Phone سیسکو توسط کد های دستوری به اختصار توضیح داده شده و در آینده مقاله ای در مورد تعویض firmware تلفن سیسکو به sip و یا آپگرید firmware , تلفن سیسکو Cisco IP Phone منتشر خواهیم کرد .

همیشه به خاطر داشته باشید که اگر برای بار اول است که میخواهید دست به چنین کاری بزنید ( و امثالهم ) ، سعی کنید که در محیط کاری و شبکه Live ، از انجام اینگونه تست ها و کسب تجربه ها بپرهیزید و محیط تست خود را به خارج از شبکه در حال کار و یا محیط های کاری انتقال داده و ایروله کنید تا باعث تاثیر بر دیگر دیوایس های سیسکو و عملکرد شبکه نگردد .

توجه داشته باشید که با ریست کردن IPPhone سیسکو تمامی CTL – LSC – Applications – History و … از بین خواهد رفت و تنظیمات تلفن سیسکو نظیر زنگ و یوزر و تصویر پس زمینه و … و همچنین تنظیمات شبکه و Call Manager بر روی گوشی به حالت اولیه باز خواهد گشت .

ریست کردن Cisco IP Phone :

ریست کردن IP Phone سیسکو در اکثر مدل های قدیمی و جدید تقریبا به یک شکل است ، در روش اول :

1 – IP Phone سیسکو را از خاموش کنید

2 – کلید # را نگه داشته و IP Phone سیسکو دوباره روشن کنید و صبر کنید تا چراغ روی گوشی چشمک زن شود .

3 – کلید # را رها و این رشته را به ترتیب وارد کنید :

123456789*0#

سپس خواهید دید که تلفن سیسکو ریبوت شده و به حالت Upgrading خواهد رفت .

( در مدل های بالاتر ، پس از وارد کردن کد فوق ، از شما در مورد ریست کردن تنظیمات شبکه تلفن سیسکو سوال میشود ، که میتوانید آنرا نگه داشته و یا ریست کنید )

اگر میخواهید Firmware تلفن سیسکو رو آپگرید و یا تغییر دهید ، میتوانید به جای کد بالا ، از این کد استفاده کنید :

3491672850*#

توجه داشته باشید که با وارد کردن این کد ، حتما میبایست به سرور Cisco Call Manager و یا TFTP Server برای بارگذاری Cisco Phone Firmware مناسب ، دسترسی داشته باشید .

پس از ریست کردن IP Phone سیسکو ، اگر از Cisco Unified Communication Manager یا CME استفاده میکنید ، تلفن سیسکو پس از DHCP طلب IP خواهد کرد و پس از دریافت IP و آدرس CUCM ، به شکل خودکار Auto Provision ، تنظیمات مربوطه را دریافت خواهد کرد .

جهت آشنایی با سیستم های جامع ارتباطات چند رسانه ای سیسکو Cisco Unified Communication ، این مقاله را مطالعه فرمایید .

وفقک الله

تنظیم Ip روی روتر سیسکو

تنظیم IP روتر سیسکو سوئیچ سیسکو

تنظیم IP روتر سیسکو سوئیچ سیسکو

کانفیگ IP روتر سیسکو

کانفیگ IP روی سوئیچ سیسکو

تنظیم IP روتر سیسکو و یا ست کردن IP روتر و یا اختصاص IP به روتر سیسکو و یا سوئیچ سیسکو اولین گام در راه اندازی قابلیت های مسیریابی routing و دسترسی از طریق آدرس دهی IP به روتر سیسکو و یا سوئیچ سیسکو است .
تنظیم IP Address مختص تجهیزات سیسکو که در لایه سه کار میکنند از قبیل سوئیچ لایه سه سیسکو و یا روتر سیسکو ، الزاما نیست ، چراکه برای دسترسی های مدیریتی میبایست اقدام به ست کردن IP بر روی سوئیچ لایه دو سیسکو نیز نمود ، کما اینکه سوئیچ های لایه ۲ سیسکو فاقد امکان مسیریابی IP هستند .

تنظیم IP روتر سیسکو ، اولین گام در  عملیاتی نمودن روتر سیسکو و یا سوئیچ سیسکو است ، چرا که ما در شبکه های IP با Subnet ها سر و کار داریم و در واقع هر شبکه محدود به یک سابنت (اصلی) است ، بدین مفهوم که هر اینترفیس محدود به Broadcast Domain همان Network که در آن آدرس دهی شده است میباشد و پکت های میبایست برای رسیدن به مقصد ، مسیریابی شوند ، که این نکته فرق اصلی روتینگ و بریجینگ است . در Bridging ما محدود به یک مدیا ، که همچنین محدود به یک تکنولوژی لایه دو ، که همه در یک Broadcast Domain هستند میشویم ،، لکن در شبکه لایه سه یا یک Routed Network ، ما با Subnet ها سر و کار داریم و همچنین یک پکت ممکن است برای رسیدن به مقصد از انواع رسانه ها و تکنولوژی های لایه ۲ با MTU های مختلف و مدیوم های متفاوت عبور کند .
در حقیقت روتر جدول مسیریابی یا همان دید خود از شبکه را از سه طریق میسازد :

۱ – شبکه های متصل به اینترفیس هایش ، Prefix – Subnet هایی که در وضعیت Connected ،، یعنی تعریف شده روی اینترفیس های حقیقی و یا مجازی روتر ( همین بحث ما که مربوط به تنظیم IP روی اینترفیس های روتر سیسکو ) است .

۲- Static Route ها .

۳- Route هایی که از طریق کارکرد Routing Protocol ها بدست می آورد ، نظیر OSPF – EIGRP – BGP و …

بنابراین ،، تعریف IP بر روی اینترفیس روتر سیسکو اولین و مهمترین قدم برای عملیاتی کردن یک روتر سیسکو  است . کمی از بحث اصلی دور شدیم ، منتها پرداختن به مفهوم و تفاوت های اصلی شبکه های لایه ۲ و شبکه های لایه سه و فرق عملیات Routing – روتینگ و Bridging – بریجینگ و همچنین تاثیر مهم شبکه های Connected بر روی صحت عملکرد روتر ،  میتواند دید شفاف تری نسبت به این امر را ،  حاصل نماید ، برای مثال اگر شما یک Prefix معروف مثل 8.8.8.0/24 ، که یکی از DNS های معروف و پر استفاده عمومی ست ، را روی یکی از اینترفیس های روتر خود ست کنید ،، ( مثلا 8.8.8.1/24 ) ، زمانی که از پشت روتر سعی کنید ۸.۸.۸.۸ را پینگ کنید ، به RTO برخواهید خورد ،، چرا که روتر در جدول مسیریابی میبیند که این سابنت به شکل Connected است ، لذا درخواست را به سمت Gateway خود نمیفرستد ،،، حتی اگر این Prefix توسط یک Routing Protocol در جدول مسیریابی نوشته شده باشد ،، به دلیل اینکه Connected Route ها بالاترین ارزش و کمترین Metric را دارند ، باز هم Packet ها به سمت مقصد هدایت نخواهد شد .

روتر سیسکو و یا سوئیچ سیسکو و کلا هر دیوایس لایه ۳ ، با پروتکل های لایه ۳ قابل آدرس دهی ( در اینجا IP ) سر و کار دارند ، لذا همانطور که ابتدا اشاره شد ، قدم اول برای راه اندازی روتر سیسکو ، اختصاص آدرس IP به اینترفیس روتر سیسکو – اینترفیس سوئیچ سیسکو است ، در واقع پس از آدرس دهی ست که روتر سیسکو ، موقعیت خود را تشخیص و شبکه متصل به اینترفیس خود را شناسایی کرده و سپس میتواند به تبادل Packet و انجام عملیات مسیریابی و تشکیل جدول مسیریابی Routing table بپردازد .

در این نوشتار برای جلوگیری از پیچیدگی ، ما به روش اختصاص IP به چند اینترفیس متداول روتر و سوئیچ سیسکو میپردازیم .

اختصاص IP به اینترفیس اترنت روتر سیسکو :

روتر سیسکو اغلب به شکل پیشفرص دارای یک یا چند اینترفیس اترنت Ethernet یا فست اترنت Fast Ethernet و یا Gigabit Ethernet هستند ، شما میتوانید برای آگاهی از اینترفیس های روتر سیسکو از این دستور استفاده کنید :

Aka-Router#: show interface summary

Aka-Router#sh interfaces summary

 *: interface is up
 IHQ: pkts in input hold queue IQD: pkts dropped from input queue
 OHQ: pkts in output hold queue OQD: pkts dropped from output queue
 RXBS: rx rate (bits/sec) RXPS: rx rate (pkts/sec)
 TXBS: tx rate (bits/sec) TXPS: tx rate (pkts/sec)
 TRTL: throttle count

Interface IHQ IQD OHQ OQD RXBS RXPS TXBS TXPS TRTL
-----------------------------------------------------------------------------------------------------------------
*FastEthernet0/0 0 516 0 0 4000 6 4000 4 35
*FastEthernet0/0.100 - - - - - - - - -
*FastEthernet0/1 0 124 0 0 1000 2 0 0 49
*FastEthernet0/1.10 - - - - - - - - -
*FastEthernet0/1.108 - - - - - - - - -
*FastEthernet0/1.109 - - - - - - - - -
*Loopback0 0 0 0 0 0 0 0 0 0
*NVI0 0 0 0 0 0 0 0 0 0
*Tunnel0 0 0 0 0 0 0 0 0 0
*Tunnel1 0 0 0 0 0 0 0 0 0
NOTE:No separate counters are maintained for subinterfaces
 Hence Details of subinterface are not shown

همانگونه که از خروجی دستور show interface sum پیداست ، لیست انواع اینترفیس های روتر اعم از اینترفیس های فیزیکی ، از قبیل Serial – OC3 – Ethernet و مجازی از قبیل Sub Interface و Tunnel و loopback نمایش داده میشوند .

برای تنظیم IP روتر سیسکو برای اینترفیس های فیزیکی نظیر FastEthernet – Ethernet – GigabitEthernet بدین ترتیب عمل مینماییم :

Aka>en
Password: 
Aka#conf t
Enter configuration commands, one per line.  End with CNTL/Z
Aka(config)#int gi 0/1
Aka(config-if)#ip address 192.168.1.1 255.255.255.0
Aka(config-if)#exit

برای انواع دیگر اینترفیس های اترنت نیز روال به همین صورت است ، فقط میبایست نام آنها را پس از دستور interface وارد نموده و سپس مطابق بالا IP Address به همراه Subnet را وارد کنید .
در صورتی که مایل باشید به اینترفیس روتر سیسکو بیش از یک IP اختصاص دهید ، لازم است که پس از وارد نمودن IP و Subnet Mask از عبارت Secondary استفاده کنید ،، این عبارت برای آدرس های سوم الی آخر فرقی نخواهد کرد ، برای مثال برای کانفیگ سومین آدرس بر روی یک اینترفیس روتر سیسکو نیز همانند IP دوم عمل کنید .
برای پاک کردن یک IP از روی اینترفیس روتر سیسکو ، در صورتی که همان یک IP بر روی آن باشد و یا بخواهید همه IP Address ها را حذف نمایید ، کافی است از دستور :

Aka#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Aka(config)#int gi 0/1
Aka(config-if)#no ip address
تنظیم ip روتر سیسکو

تنظیم ip روتر سیسکو

تنظیم IP Address بر روی اینترفیس سریال روتر سیسکو

اینترفیس های سریال روتر سابق بر این استفاده های گسترده ای در اتصالات wan در ارتباط روتر سیسکو با dsu/csu ها مثل مودم های G.SHDSL – ATM – E1 و … داشتند ، که با پیشرفت تکنولوژی و افزایش نیاز به سرعت های بالاتر ، استفاده از این نوع اینترفیس به علت منسوخ شدن تکنولوژی های مرتبط  ، آنچنان مرسوم نیست و دیگر کمتر روتری را میبینیم که مجهز به wic 1t یا wic 2t باشد ، معذالک ذکر روش تنظیم آدرس IP بر روی اینترفیس های سریال که البته به ندرت اتفاق میافتاد خالی از لطف و مرور خاطرات نیست :

Shabake(config)# interface serial 0/0/0
Shabake(config-if)# description Link to R2
Shabake(config-if)# ip address 209.165.200.225 255.255.255.252
Shabake(config-if)# clock rate 128000
Shabake(config-if)# no shutdown
Shabake(config-if)# exit
تنظیم ip روی سریال روتر سیسکو

تنظیم ip روی سریال روتر سیسکو

تنظیم IP Address بر روی پورت سوئیچ لایه سه سیسکو

سوئیچ های لایه سه سیسکو امکان مسیریابی را دارا میباشند ، بنابراین میتوانید بر روی اینترفیس های سوئیچ لایه سه سیسکو ، نظیر سوئیچ سیسکو 3560 و سوئیچ سیسکو 3750 ، IP ست کنید ،
برای تنظیم آدرس IP روی سوئیچ سیسکو ، بدین ترتیب عمل کنید :

Aka-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Aka-3750(config)#int gi 1/0/16
Aka-3750(config-if)#no switchport
Aka-3750(config-if)#ip address 192.168.57.1 255.255.255.0
Aka-3750(config-if)#exit
Aka-3750(config)#do sh run int gi 1/0/16
Building configuration...
Current configuration : 93 bytes
!
interface GigabitEthernet1/0/16
 no switchport
 ip address 192.168.57.1 255.255.255.0
end

ست کردن IP روی اینترفیس های مجازی روتر سیسکو – سوئیچ سیسکو

vlan ها ، تانل ها ( tunnel ) ، لوپ بک ( loopback ) ، ساب اینترفیس ها ( sub interface ) , … جزء اینترفیس های غیر فیزیکی که به آنها میتوان اینترفیس های مجازی ، از لحاظ ابعاد وجودی البته ، اطلاق کرد ، برای مثال شما میتوانید بر روی یک Vlan حتی در یک سوئیچ لایه 2 سیسکو ، IP ست کنید ، لکن ، این IP تنها به جهت دسترسی به سوئیچ قابل استفاده خواهد بود و استفاده های لایه سه ای نخواهد داشت :

Aka-3750#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Aka-3750(config)#int vlan 301
Aka-3750(config-if)#ip address 192.168.65.1 255.255.255.0
Aka-3750(config-if)#exit
Aka-3750(config)#do sh run int vlan 301
Building configuration...
Current configuration : 64 bytes
!
interface Vlan301
 ip address 192.168.65.1 255.255.255.0
end

همچنین در مواردی که یک سوئیچ سیسکو را با یک روتر سیسکو ، به جهت استفاده از intervlan routing ترانک کرده و یا به هردلیل نیازمند استفاده از VLAN ها بر روی روتر سیسکو هستید ، به سادگی میتوانید از sub interface ها که قبلا توضیح آن در نوشتاری گذشت ، IP ست کنید :

 Aka-Core#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Aka-Core(config)#int gi 0/1.312
Aka-Core(config-subif)#encapsulation dot1Q 312
Aka-Core(config-subif)#ip address 192.168.66.1 255.255.255.0
Aka-Core(config-subif)#exit
Aka-Core(config)#do sh run int gi 0/1.312
Building configuration...
Current configuration : 119 bytes
!
interface GigabitEthernet0/1.312
 encapsulation dot1Q 312
 ip address 192.168.66.1 255.255.255.0
 no cdp enable
end

تنظیم IP Address روی اینترفیس loopback روتر سیسکو

اینترفیس های LOOPBACK یک عضو بی بدیل بر روی روتر های سیسکو هستند ،، آنها مجازی هستند و به هیچ جا متصل نیستند لکن ، به دلیل اینکه هیچ وقت Down نمیشوند ، در عمل ، امکانات مدیریتی مهمی در تنظیم روتر سیسکو به ارمغان می آورند ،، اینترفیس های لوپ بک ، این اطمینان را به شما میدهند که یک اینترفیس حداقل روی روتر سیسکو همیشه UP ، و دارای یک IP مشخص است ،، اغلب IP Address تنظیم شده بر روی اینترفیس loopback روتر سیسکو ، به عنوان IP اصلی روتر در مواقع مختلف مورد استفاده قرار میگیرد .

shabake(config)#interface loopback 0
Shabake(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
shabake(config-if)#ip address 192.169.1.1 255.255.255.0

در مجموع ، ذر شبکه های لایه سه مبتنی بر IP ، اولین و بنیادی ترین بخش ، آدرس های IP هستند ، این آدرس ها هستند که Routing Table روتر ها را میسازند و امکان کارکرد شبکه جهانی اینترنت را میسر میکنند .
البته در سالهای اخیر ، IP Version 4 به دلیل محدودیت تعداد ، تقریبا به اتمام رسید ، و تمامی Valid IP های version 4 ، در دنیا توسط سازمانهای جهانی Ripe Iana Arin ، واگذار Allocate شدند و همکنون دنیا به سمت استفاده از IP Version 6 میرود .
باشذ که هرچه زودتر زیرساخت های لازم جهت بهره برداری از IP V6 در ایران ،  راه اندازی گردد ، تا بازار سیاه و کثیف مبادله IP V4 از سکه و تب و تاب افتد :دی …

وفقک الله

سیسکو BGP AS Prepend

آموزش پیاده سازی BGP AS Prepend روتر سیسکو

آموزش کانفیگ BGP AS Prepend روتر سیسکو

پیاده سازی Cisco BGP AS Prepend جهت BGP Multihoming در روتر سیسکو

BGP AS Prepend یکی از تکنیک های مدیریت مسیریابی BGP و افزایش پایداری ( Fail over ) در شبکه های روتینگی مبتنی بر BGP است ، بدین ترتیب که با توجه به الگوریتم انتخاب مسیر BGP که یکی از مولفه های آن Shortest AS Path است ، میتوان نحوه تصمیم گیری BGP برای انتخاب بهترین مسیر را تحت تاثیر قرار داد .

BGP AS Prepend با استفاده از این معیار که BGP برای انتخاب بهترین مسیر به تعداد AS های موجود در مسیر توجه میکند ، عمل می نماید ، در واقع یکی از عوامل تاثر گذار در تصمیم گیری BGP برای انتخاب Best Route ، کوتاهترین مسیر از لحاظ تعداد AS های مسیر است و BGP AS Prepend روشی است که در آن ما یک AS را برای Adv کردن Prefix های خود به سمت یک BGP Peer چندین بار تکرار میکنیم ، بنابراین روتر سیسکو همسایه ، گمان میکند طول این مسیر از لحاظ AS Path به همان میزان تکرار شدن AS ، طولانی تر از حالت عادی است ، برای مثال به این Route توجه کنید :

route-views>sh ip bg 10.10.10.0
BGP routing table entry for 10.10.10.0/24, version 51853444
Paths: (35 available, best #35, table default)
 Not advertised to any peer
 Refresh Epoch 1
 7018 1299 12880 49689 44066
 12.0.1.63 from 12.0.1.63 (12.0.1.63)
 Origin IGP, localpref 100, valid, external
 Community: 7018:5000 7018:37232
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 6079 2914 9498 8529 8529 8529 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 49689 44066
 207.172.6.1 from 207.172.6.1 (207.172.6.1)
 Origin IGP, metric 0, localpref 100, valid, external
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 1239 1299 12880 49689 44066
 144.228.241.130 from 144.228.241.130 (144.228.241.130)
 Origin IGP, localpref 100, valid, external
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 4826 2828 1299 12880 49689 44066
 114.31.199.1 from 114.31.199.1 (114.31.199.1)
 Origin IGP, localpref 100, valid, external
 Community: 4826:5901 4826:6150 4826:59011
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 6539 577 174 8529 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 49689 44066
 66.59.190.221 from 66.59.190.221 (66.59.190.221)
 Origin IGP, localpref 100, valid, external
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 3303 3320 1299 12880 49689 44066
 217.192.89.50 from 217.192.89.50 (138.187.128.158)
 Origin IGP, localpref 100, valid, external
 Community: 3303:3006 3303:3067 3303:8199 3320:1250 3320:2010 3320:9020
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 7660 2516 6453 8529 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 49689 44066
 203.181.248.168 from 203.181.248.168 (203.181.248.168)
 Origin IGP, localpref 100, valid, external
 Community: 2516:1050
 rx pathid: 0, tx pathid: 0
 Refresh Epoch 1
 852 174 8529 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 12880 49689 44066
 154.11.98.225 from 154.11.98.225 (154.11.98.225)
 Origin IGP, metric 0, localpref 100, valid, external

همانطور که در خروجی ملاحظه میفرمایید ، ISP ها در سطوح مختلف اقدام به استفاده از BGP AS Prepend جهت مدیریت بر UpLink ها به لحاظ میزان Congested بودن هر کدام و همچنین تحمل قطعی ارتباط و تحمل خرابی و بنا به سیاست های داخلی خود ، بر روی روتر های سیسکو مرزی BGP Edge خود نموده اند .

BGP AS Prepend به سادگی به کمک یک Route-Map بر روی روتر سیسکو و ارتباطات BGP قابل پیاده سازی است ، برای مثال در صورتی که یک سازمان ارتباط خود با اینترنت را از طریق چند ISP فراهم نموده باشد ، میتواند با استفاده از BGP AS Prepend ، موازینی تعیین کرده و Prefix های خود را به همه BGP Peer های خود ارسال کند ، و بنا بر اولویت در هنگام تبلیغ Adv ، به آن AS Prepend بزند .


برای روشن تر شدن مسئله از یک مثال استفاده میکنیم ،

آموزش کانفیگ BGP AS Prepend

آموزش کانفیگ BGP AS Prepend

مطابق دیاگرام فوق ، سازمان مربوطه ، ارتباط به اینترنت خود را از طریق دو ISP که با آنها ارتباط BGP دارد تامین میکند . سازمان مورد نظر ما ، دارای 2 کلاس Valid IP است که توسط AS#300 آنها را تبلیغ Advertise مینماید . همانطور که ملاحظه میفرمایید ، پهنای باند اینترنتی از طریق ISP1 به میزان 10 مگابیت و از طریق ISP2 به میزان 20Mb/s است و همچنین اولویت استفاده از سروریس ISP 2 است و ارتباط ISP 1 به عنوان BackUp در نظر گرفته شده است .
بنابراین مدیر شبکه سازمان مربوطه تصمیم میگیرید که هر دو Prefix خود را به سمت هر دو ISP تبلیغ کند به طوری که ترافیک به شکل پیشفرض از سمت ISP2 سرازیر شود و در صورت بروز مشکل در ISP2 ، ارتباط از طریق ISP1 برقرار بماند .

در اینجاست که مزیت بزرگ BGP AS Prepend خودنمایی میکند ،، لذا برای پیاده سازی این استراکچر ، لازم است Prefix ها را به سمت دو ISP ارسال و در مورد ISP1 ، کافی است AS Number را دوبار تکرار Prepend کنیم :

router bgp 300
 network 1.1.1.0 mask 255.255.255.0
 network 2.2.2.0 mask 255.255.255.0
 neighbor 192.168.1.1 remote-as 100
 neighbor 192.168.1.1 description ISP2
 neighbor 192.168.1.1 route-map prepend out
 neighbor 192.168.2.1 remote-as 200
 neighbor 192.168.2.1 description ISP1

!
route-map prepend permit 10
 set as-path prepend 300 300

بدین ترتیب هر دو Prefix به هر دو ISP بالادست Advertise میشود ، فقط در AS Path برای ISP1 ، مشاهده خواهد شد که AS300 دو مربته بیشتر تکرار شده است .
باید توجه داشت که ممکن است در عین حالی که ما به میزان 2 AS طول مسیر را برای ISP1 طولانی تر کرده ایم ، اما اگر این ISP روت های بهتری در دنیا داشته باشد ، ممکن است باز ترافیک از سمت آن سرریز شود ، لذا اغلب برای اطمینان از این مسئله تعداد دفعات BGP AS Prepend را بیش از 5 بار تنظیم میکنند .
ذکر این نکته نیز خالی از لطف نیست، چندین سال پیش ، ادمین یک ISP در آسیای شرقی ، با prepend زدن نادرست و به تعداد بسیار بالا ، مشکل عظیمی در اینترنت به وجود آورد و باعث فلج شدن شبکه گردید!

جهت بررسی عملکرد BGP AS Prepend ، به سادگی میتوانید ، با استفاده از یکی از Route Server های Public و یا BGP Looking Glass های موجود ، به بررسی صحت عملکرد BGP و نحوه مشاهده شبکه شما از بیرون بپردازید .

حتما توجه داشته باشید که این تکنیک بر روی نحوه advertise شدن Prefix های شبکه تاثیر دارد ، در واقعا این عملیات Down Stream شبکه شما را کنترل میکند ، لذا میبایست جهت FailOver در حط send نیز از تکنیکی نظیر Floating Static Route به همراه IP SLA که قبلا به آن پرداخته ایم ، استفاده کنید .

وفقک الله